Seafile Server Pro Update 7.0.4 to 7.1.4

Hi,

if i want to access seafile i get an internal server error. the following error is displayed in the seahub.log ModuleNotFoundError: No module named ‘ranged_response’

I have a Linux server Ubuntu 18.04

my pip3 list

aggdraw (1.3.11)
asgiref (3.2.7)
asn1crypto (0.24.0)
attrs (19.3.0)
captcha (0.3)
cryptography (2.1.4)
cycler (0.10.0)
decorator (4.4.2)
Django (3.0.6)
django-pylibmc (0.6.1)
django-ranged-fileresponse (0.1.2)
django-ranged-response (0.2.0)
django-recaptcha (2.0.6)
django-simple-captcha (0.5.12)
docopt (0.6.2)
idna (2.6)
imageio (2.8.0)
Jinja2 (2.11.2)
keyring (10.6.0)
keyrings.alt (3.0)
kiwisolver (1.2.0)
MarkupSafe (1.1.1)
matplotlib (3.2.1)
netifaces (0.10.4)
networkx (2.4)
numpy (1.18.4)
Pillow (7.1.2)
pip (9.0.1)
pyasn1 (0.4.8)
pycrypto (2.6.1)
pygobject (3.26.1)
pylibmc (1.6.1)
pyparsing (2.4.7)
python file style (2.8.1)
python3-ldap (0.9.8.4)
pytz (2020.1)
PyWavelets (1.1.1)
pyxdg (0.25)
PyYAML (3.12)
scikit-image (0.16.2)
scipy (1.4.1)
SecretStorage (2.3.1)
setuptools (39.0.1)
six (1.15.0)
SQLAlchemy (1.3.17)
sqlparse (0.3.1)
wheel (0.30.0)

Can’t fix the error
Would be glad about your help

Did you install Python 3? Version 7.1 switched to Python 3.

Yes I have the version 3.6.9

Interesting… I think that it’s trying to call the ranged_response module in DJango, but I would have to dig into the code to verify.

Unfortunately, error logging in Python can be quite tedious. What Linux distro do your have this installed upon? Also, I noticed that your Python3 is slightly outdated. Though that probably isn’t the problem, updating it may fix something that is broken. It’s worth trying.

The Seafile manual has some information on upgrading to 7.1 from earlier versions. It details installing/upgrading new dependencies, and, at the very bottom, it details what to do in case you get internal server errors. I would try going through the steps in this section of the manual.

https://download.seafile.com/published/seafile-manual/upgrade/upgrade_notes_for_7.1.x.md