Seafile server version 3.0.4

Dear team,
Need help. our seafile server is running on Ubuntu 12.04 and the status is

root@filesrv:~# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/vda1 183G 166G 7.1G 96% /
udev 7.2G 4.0K 7.2G 1% /dev
tmpfs 1.5G 280K 1.5G 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 7.2G 0 7.2G 0% /run/shm

i done GC also nothing is happening

I am taken whole seafile server backup yesterday, is there any possibility to restore that in new ubuntu 16.04 machine
thanks in advance

It really depends…

Do you have any ver 1 libraries?
Are you using encryption on any libraries?
Is it possible for you to just “start over” with a new hard drive and fresh install of the OS and Seafile?

With your Seafile Server being so old, my advice would be to upgrade the hdd, upgrade the OS, fresh install Seafile, and resync the the actual files to new libraries rather than trying to go through the entire script after script after script in order to update those libraries.

Thanks for your reply @wthess

in seafile there is directory called seafile-data all contents are like encrypted one
whether these data will work if i install latest seafile server
thanks in advance

If they are encrypted, it depends… If those repositories were encrypted prior to ver 3, you may have a problem, even if you do use the same key. Did you sync those files to a client by any chance?

yes i had synced in one windows client machine

Set up a new one, you’ll get dependency problems.

Then I would start fresh. Set up the lastest Seafile and then sync those files from that client to new libraries on the Server.

while installing seafile it is giving error

seafile@server:/opt/seafile-server-6.2.5$ ./seafile.sh start

/opt/ccnet/seafile.ini not found. Now quit
seafile@server:/opt/seafile-server-6.2.5$

i dont know why it is happening

Did you run ./setup-seafile-mysql.sh or ./setup-seafile.sh (if you not want to use MySQL, which i don‘t recommend)?

yes i ran script as a seafile user, after that i run the script as a root user now it is working

Ok but now you should do a chown on your Seafile Folder with the Seafile User. Don’t run Seafile as root.

ok thanks @marcusm

while installing seafile in ubuntu 12.04 iam getting this error

/newhome/seafile-server-6.2.5/seafile/bin/ccnet-init: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17’ not found (required by /newhome/seafile-server-6.2.5/seafile/lib/libblkid.so.1)

@marcusm @wthess
need your help. I install seafile server now it is up and running normally and I install as a root
so I need to change ownership of the complete folder

example: chown -R seafile:seafile ccnet conf logs pids seafile-data seafile-server-6.2.5 seafile-server-latest seahub-data

is it correct or not
i have to change chown to all folder or not

Yes, this would work. If there aren’t any other files or folders inside the opt folder, you can just do chown -R seafile:seafile /opt

1 Like

As @bionade24 said, you need a newer linux / ubuntu version.

1 Like

I’m also in agreement with @bionade24 and @marcusm. You should upgrade Ubuntu. Ubuntu 12 came out in 2012.

1 Like