Seafile took over my server

Hello all.

New to Seafile. I just installed it via Docker. Everything works great, I can upload, vew and download everything on Seafile as expected so really impressed.

However it’s taken over my whole server, during setup I requested it be installed at

Which works fine, however if I go to any other domain address it just loads seafile. For instance I went to :

both loaded Seafile. That wasn’t really the type of install I was looking for :confused: I assume it has something to do with the port it used. But any ideas how I might go about fixing it so it only works on

Thanks :smiley:

Ok, so it’s definately to do with the port used. In the install instructions it says to use port 80 which I did, but Apache uses port 80.

For now I’ve killed Seafile and restarted Apache so at least my websites load.

Any ideas how to edit which port it uses and recommend which port I should use? Or will it just not work side by side with a web server?


Since you use Apache, look into setting up “Virtual Hosts”. I use Nginx as a reverse proxy with my installation and have 3 sites running off the same box.

You just can have one Webserver for one IP, so that it can handle the SNIs and load the different sites, so put a reverse proxy in front of the container, just let the ports and / directory trough, and it will work.