Seafile und Wordpress auf einem NGINX Server


#21

Wordpress nutze ich nur für eigene Spielereien und nicht einen öffentlichen Blog. Daher ist das Unterverzeichnis kein Problem.


#22

Macht der Gewohnheit.


#23

Sieht soweit ja eigentlich okay aus. Hast du deine IPTables ggf. komplett dicht gemacht dass er solche Verbindungen auch verbietet?

Probiere bitte mal mit nmap -p 3000 ob der Dienst sauber antwortet.


#24

Sieht für mich ok aus:
sudo nmap 127.0.0.1 -p 3000

Starting Nmap 6.47 ( http://nmap.org ) at 2018-02-06 13:42 CET
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00032s latency).
PORT STATE SERVICE
3000/tcp open ppp

Nmap done: 1 IP address (1 host up) scanned in 0.77 seconds

Wenn ich seafdav wieder auf fastcgi umgestelle, klappt der Webdav-Zugriff problemlos.

Ich hatte noch im Hinterkopf, gelesen zu haben dass seafdav weiter über fastcgi läuft. Habe nun den Beitrag gefunden: https://forum.seafile.com/t/seafile-server-6-2-0-beta-is-ready-for-testing/3941/7 Da hattest Du selbst nachgefragt, aber wohl keine Antwort bekommen. Ich denke, ich behalte einfach meine laufende Konfiguration bei.
Vielen Dank für Deine Hilfe!


#25

Ich habe es jetzt gerade extra noch einmal getestet. Ich habe es definitiv ohne fastCGI laufen.
Kannst du deine Nginx Version mal bitte auf die neuste Version update?

https://launchpad.net/~nginx/+archive/ubuntu/stable

Von extern greifst du dann via https://my.seafile.domain/seafdav darauf zu korrekt?


#26

Make sure to not pass the fast cgi option on start.


#27

Werde ich mal testen, klappt aber gerade nicht:

W: Fehlschlag beim Holen von http://ppa.launchpad.net/nginx/stable/ubuntu/dists/jessie/main/binary-armhf/Packages 404 Not Found

Ich hoffe, dass da nur vorübergehend was fehlt - versuche es später noch einmal.
Via WebDAV greife genau so zu, wie Du geschrieben hast. Der Zugriff auf das Seafile Webinterface klappt ja auch problemlos ohne fastcgi. Grundsätzlich läuft es ja, so dass ich keinen wirklich dringenden Handlungsbedarf habe.


#28

@shoeper: Klar, seahub starte ich ohne den fastcgi Zusatz. Klappt auch alles problemlos - auch der WebDAV Zugriff. Meine nginx Konfiguration steht ja weiter oben im Thread. Ist halt nur komisch, dass der WebDAV Zugriff nicht ohne fastcgi klappt.


#29

Für WebDAV gibt es ne eigene Konfigurationsdatei.

seafdav.conf


#30

Ich dachte dass ihm das klar sei, anscheinend nicht. \o/


#31

Doch ist klar. Sorry, hatte @shoeper falsch verstanden. :blush:
Meine laufende seafdav.conf sieht so aus:

[WEBDAV]
enabled = true
port = 3000
fastcgi = true
share_name = /seafdav
host = localhost

Für den Test der nginx Konfiguration von @DerDanilo hatte ich fastcgi auf false gesetzt und sowohl nginx als auch seafile neu gestartet.
Leute, lasst es erst mal gut sein. Ich habe inzwischen beschlossen, mir einen neuen Homeserver auf Intel NUC Basis aufzubauen. Wenn es dann bei der seafile Installation Probleme gibt, komme ich gern noch mal auf euch zurück.
Vielen Dank für die Hilfe bis hierhin.


#32

here is mine:

root@hiperborea /home/seafile/conf # cat seafdav.conf
[WEBDAV]
enabled = true
port = 8080
fastcgi = false
share_name = /seafdav

You have to double check that no empty spaces after true, 8080, false, etc