Seafile under HTTPS on Docker

I’m installing Seafile 10.0.1 Community in a Docker container. I’m running Unraid, but I don’t know if that matters for my question.

The container’s IP is When I run ‘curl -I http://:80’, I get back a 302. But when I run ‘curl -I https://:443’, I get back a ‘Failed to connect’ instead.

I’ve set SERVICE_URL in the web gui to https://<seafile.mydomain>.com - does that turn on SSL, or is there something else I need to do? Should trying to connect to port 443 the way I’m doing it even work?

What is the output of docker logs seafile?

*** Running /etc/my_init.d/…
*** Booting runit daemon…
*** Runit started as PID 23
*** Running /scripts/…
2023-04-21 18:32:57 Nginx ready
2023-04-21 18:32:57 This is an idle script (infinite loop) to keep container running.
[04/21/2023 18:32:57][upgrade]: The container was recreated, start fix the media symlinks
[04/21/2023 18:32:57][upgrade]: Done

Starting seafile server, please wait …
** Message: 18:32:57.533: seafile-controller.c(621): No seafevents.

Seafile server started


Starting seahub at port 8000 …

Seahub is started