Seafile Worktree for repo "repo" is invalid, delete it

Hi all

In older seafile client version i used to synchronize a repo to a nfs folder from my laptop. When I was not in the office the laptop realized that the nfs folder is not available and seafile client interrupted synchronization until it came available.

with the latest seafile client on ubuntu linux I realize now that it stops synchronizing forever once the folder became unavailable, writing the error
seafile Worktree for repo “repo” is invalid, delete it.

I then have to setup synchronization again and it takes quiet a long time until seafile realizes that the folders are synchronized.

Is there a way to bring back the feature we had in older clients?

I think it is still available in the settings menu.

Thank you shoeper,
where exactly could I find the corresponding setting?
I didn’t get it.
Thank you.

Open Seafile client settings, there is bookmark “Advanced” and there is checkbox with label “Do not automatically unsync a library”.

2 Likes

Thank you. I found it and I am testing it now.

it is working perfectly. THANK you.

1 Like

Please mark response as solution for other users solving same problem :slight_smile: