Seahub failed to start #15684684

Hi there.
The install and initial config was straight forward. After configuring seahub it does not start. Seems like captcha module is making issues. Any idea?
What I did:

  • start-fastcgi
  • dir permission
  • dir ownership
  • re download & clean install
  • restart the server
  • different ports

=======================================
LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub (fastcgi) at 127.0.0.1:8124 …
Traceback (most recent call last):
File “/home/medias/p_dir/fileserver/seafile-server-7.1.4/seahub/manage.py”, line 10, in
execute_from_command_line(sys.argv)
File “/home/medias/p_dir/fileserver/seafile-server-7.1.4/seahub/thirdpart/django/core/management/init.py”, line 364, in execute_from_command_line
utility.execute()
File “/home/medias/p_dir/fileserver/seafile-server-7.1.4/seahub/thirdpart/django/core/management/init.py”, line 338, in execute
django.setup()
File “/home/medias/p_dir/fileserver/seafile-server-7.1.4/seahub/thirdpart/django/init.py”, line 27, in setup
apps.populate(settings.INSTALLED_APPS)
File “/home/medias/p_dir/fileserver/seafile-server-7.1.4/seahub/thirdpart/django/apps/registry.py”, line 85, in populate
app_config = AppConfig.create(entry)
File “/home/medias/p_dir/fileserver/seafile-server-7.1.4/seahub/thirdpart/django/apps/config.py”, line 94, in create
module = import_module(entry)
File “/usr/lib/python3.6/importlib/init.py”, line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 994, in _gcd_import
File “”, line 971, in _find_and_load
File “”, line 953, in _find_and_load_unlocked
ModuleNotFoundError: No module named ‘captcha’
Error:Seahub failed to start.

Did you install the python module captcha ?

Yes, i did. Installed every module with captcha but still no luck. I receive the same error.

Try to install the module for the specific python version:

python3.6 -m pip install captcha

I faced this problem on debian10 with python3.8. However, in my case it’s not related to non-installed modules. There are no reports in logs “ModuleNotFoundError:…”. It worked well and I guess that automatic debian update broke something.

Thank you. Worked! I had install pip to the Python 3.6… then install the ‘captcha’ module