Seahub failed to start (SYNTAX ERROR)

seadrive

#1

I followed this guide and everything went well until the end the guide was from linux dot com (how to install seafile server run private cloud)

This is the error I’m getting when trying to start seahub

root@illaspire:/var/www/sea/seafile-server-6.2.5# /var/www/sea/seafile-server-latest/./seahub.sh start-fastcgi

LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub (fastcgi) at 127.0.0.1:8000 …
Traceback (most recent call last):
File “/var/www/sea/seafile-server-6.2.5/seahub/manage.py”, line 10, in
execute_from_command_line(sys.argv)
File “/var/www/sea/seafile-server-6.2.5/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/core/management/init.py”, line 354, in execute_from_command_line
utility.execute()
File “/var/www/sea/seafile-server-6.2.5/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/core/management/init.py”, line 303, in execute
settings.INSTALLED_APPS
File “/var/www/sea/seafile-server-6.2.5/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/conf/init.py”, line 48, in getattr
self._setup(name)
File “/var/www/sea/seafile-server-6.2.5/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/conf/init.py”, line 44, in _setup
self._wrapped = Settings(settings_module)
File “/var/www/sea/seafile-server-6.2.5/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/conf/init.py”, line 92, in init
mod = importlib.import_module(self.SETTINGS_MODULE)
File “/var/www/sea/seafile-server-6.2.5/seahub/thirdpart/importlib-1.0.4-py2.6.egg/importlib/init.py”, line 37, in import_module
import(name)
File “/var/www/sea/seafile-server-6.2.5/seahub/seahub/init.py”, line 3, in
from handlers import repo_created_cb, repo_deleted_cb
File “/var/www/sea/seafile-server-6.2.5/seahub/seahub/handlers.py”, line 4, in
import settings
File “/var/www/sea/seafile-server-6.2.5/seahub/seahub/settings.py”, line 695, in
import seahub_settings
File “/var/www/sea/conf/seahub_settings.py”, line 3
FILE_SERVER_ROOT = ‘192.168.0.29/seafhttp’
^
SyntaxError: invalid syntax
Error:Seahub failed to start.

Any suggestions? Thanks in advance!


#2

I am no expert but I have got a seafile server running well. A few thoughts:

  1. I thought fastcgi was not supported now so you might want to drop the -fastcgi switch when you start up

  2. I don’t think your FILE_SERVER_ROOT = ‘192.168.0.29/seafhttp’ statement is right. The ^ gives it away. The community manual has an example of FILE_SERVER_ROOT = ‘http://192.168.1.2/seafhttp’ you have no http:// in it so try FILE_SERVER_ROOT = 'http://192.168.0.29/seafhttp’

Good luck!