Seahub failing to start (Solved)


#1

Hi. I have had a Community Edition Seafile (version 6.3.4) running on Ubuntu 18.04 for a couple of months with no issues. Today I wanted to shut the server down but for some reason “Sudo shutdown now” did not work. That has never happened before.

I reset the server, Seafile starts normally but Seahub fails with

LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub at port 8000 …
Error:Seahub failed to start.
Please try to run “./seahub.sh start” again

I’ve looked in all the logs and there are no clues as to what is wrong. I’ve searched this forum and found similar sounding issues but no definitive approach to diagnosing the problem. I’ve tried running seahub as root with the same result so probably not a permissions issue. I’ve deleted all the .pyc files and anything seahub related in /tmp. None of this has produced a different result.

Any ideas where I go from here? Thanks in advance

John


#2

Ok, I don’t know why but a second reboot seems to have restored normal service.

I’d still like to know if there is a way to access more explicit logs of the seafile/seahub services. I’ve read that you can start the service with fastcgi to get more information but this is not available in the latest release. Did anything replace it?


#3

You can set DEBUG=true in seahub_settings.py


#4

Thanks for the information. I’ve added it to seahub_settings.py and hashed it out until needed. :slight_smile:


#5

Please mark as solved