Seahub log file empty


#1

Hi,

I have a Pro server 6.1.8 running on Ubuntu 16.04 LTS. When setting up fail2ban for it i noticed that seahub.log has nothing in it and looks like its been like that for over a month now. I couln’t find any info where to set log locations or log levels or any other info about similar behaviour. The file exists and is writeable by the server. Restarting the server didn’t help either.

Any ideas how to fix this?

Thanks!


#2

Any news on this? No change after upgrading to pro server 6.1.9…


#3

Well, we need some more info from you, what permissions do you have on the log files?
Have you tried to delete the seahub.log file and then create it again?
Have you tried to trigger a bad login so it generates a line in the seahub.log file?
Remember that 3 bad logins generate one line.


#4

Hi,

my logs are 644 and owned by seafile user. I tried to trigger bad logins too, and they worked in a way that the user got unactivated by seafile, but still nothing in the log. However after upgrading to Ubuntu server 17.10, the log started working, so i guess there was some issue that got self-solved.


#5

Just a note 17.10 are not recommended.


#6

What is it that are written in seahub.log?