Seahub refuses to start (Seafile 6.3.4)

Hi guys,

Recently I rescued an old seafile instance from a server… what I have here is seafile-data and the general seafile directory (logs, ccnet etc) and the database

I’ve got everything set up, the database back up etc but when I try to start seahub I get “Error:Seahub failed to start.” and absolutely nothing helpful, I’ve tried adding DEBUG=True into conf/seahub_settings.py but it still just gives me this really generic error

It could be a Python module I missed, maybe a mismatched version or something? but without an error I’m finding it really difficult to tell what’s wrong… I tried fastcgi to see if I could get a better error and that doesn’t work either

Any way to get Seahub to tell me specifically what’s the problem?

I could imagine, that you had choose the wrong file. Should not be gunicorn.conf instead of seahub_settings?

That didn’t work either… but I ended up downloading another copy of seafile 6.3.4, installing normally with a throwaway DB and throwaway seafile-data then pointing the config at the old seafile-data and DB

Seems to be working!