Seahub won't start after running minor_upgrade.sh

server

#1

Hello,

I am pretty sure I borked my running installation. Also I did read most of the similarly named threads and tried their to solutions to no avail.

OS: Debian 9, arch: arm using the rpi release 6.3.4

What happened: I got confused by the version in the demo site and thinking a new CE version was I out I set out to upgrade. Did not follow the normal upgrade of extracting new version because I saw the upgrade dir and not thinking twice used the minor_upgrade.sh (or similarly named) after stopping seafile / seahub.

What happens now is that seafile starts fine but seahub throws either:

Starting seahub at port 8000 ...

Seahub is started

Done.

and seahub doesn’t start or:

Starting seahub at port 8000 ...
Error:Seahub failed to start.
Please try to run "./seahub.sh start" again

also while seafile.log gets updated, seahub.log has not been updated since the “upgrade”.

permissions / ownership is fine, tried removing and re-extracting seafile-server_6.3.4_stable_pi.tar.gz

:/opt/seafile$ ls -ltr
total 43272
drwxr-xr-x 6 loke loke     4096 Oct 13  2018 seafile-server-6.3.4
-rw-r--r-- 1 loke loke 43254025 Oct 14  2018 seafile-server_6.3.4_stable_pi.tar.gz
drwxr-xr-x 2 loke loke     4096 Feb 26 19:35 logs
drwxr-xr-x 4 loke loke     4096 Feb 26 19:36 seahub-data
drwx------ 2 loke loke     4096 Feb 26 19:36 conf
-rw-r--r-- 1 loke loke  1024000 May 15 22:27 seahub.db
drwx------ 6 loke loke     4096 May 15 23:52 ccnet
drwxr-xr-x 2 loke loke     4096 May 15 23:52 pids
lrwxrwxrwx 1 loke loke       20 May 16 23:49 seafile-server-latest -> seafile-server-6.3.4

:/opt/seafile$ ls -ltr logs/
total 1948
-rw-r--r-- 1 loke loke  109408 May 15 22:33 seahub.log
-rw-r--r-- 1 loke loke   12686 May 15 23:52 controller.log
-rw-r--r-- 1 loke loke   16859 May 16 23:41 ccnet.log
-rw-r--r-- 1 loke loke 1831380 May 16 23:47 seafile.log

Any help trying to troubleshoot / fix my mistake would be appreciated.


#2

anyone can offer some help?

plan B would be to somehow keep the data and import them on a new installation