Seahub won't start

I can’t get seahub to start.

runtime/error.log and runtime/access.log are empty as well as the logs/seahub*.log files.
In the seahub.sh script, I removed the -c parameter to force it to run in the foreground and print out any errors it encounters. After giving access to /tmp/seahub_cache to my seafile user, I am not getting any errors.

Some additional info: When I add the -c parameter back in, it says that seahub started successfully. However, it’s not running. If I increase the timeout of the sleep from 5 to 10, the script tells me that it couldn’t start seahub. So it seems that seahub starts and then crashes after some time.

I am using seahub pro 5.1.10 with 3 users on Ubuntu 14.01

What are my next steps?

Anything in logs/seahub.log ?

Do you mean “-c” in this line?

    $PYTHON $gunicorn_exe seahub.wsgi:application -c "${gunicorn_conf}" -b "0.0.0.0:${port}" --preload

Then you should not do that, -c is the flag that specifies the runtime conf time. If you want to make it not daemonize, change daemon = True in runtime/seahub.conf to daemon = False instead.

As I said, logs/seahub.log is empty. And removing the -c was just for testing purposes. It’s not working when it is there either.

Have you installed python-urllib3 library?

Yes, I just checked again, I have the newest version

Last time I had this kind of problem, I run Seahub in fastcgi mode and found some error messages in Nginx’s log. Maybe you can check Nginx or Apache’s log.

I am using ./seahub.sh start, so I think I am not using fast CGI. Is it possible that some libraries for the built in web server are missing?

Oh boy… The port 8000 was already in use by another application. using start-fastcgi resulted in that error being printed to runtime/error.log. This really should happen with start as well.
It’s a stupid error but without an error message this has just cost me 3 hours…