Selfsigned certs with LineageOS 14.1


#1

Hello,
i want to use a seafile server on my private server at home.
I want to use selfsigned certs, but the seafile app (android LineageOS 14.1) say not trusted and another app (Synchronize Ultimate) reports the error:
java.security.cert.CerPathValidatorExcept
ion: Trust anchor for certification path not found.
I have signed the the certs with a self created root CA and i have imported the public root key.
Furthermore i tried it with Android 6 and it works fine with both apps (Seafile and Synchronize Ultimate)


#2

Are you sure the certificate has been imported properly? Afaik there are multiple stores for different kinds of certificates and only some will be used for tls connections.


#3

Yes i think so.
I had imported it in the same way as i did with the Android 6 device.
Furthermore i tried it to install for Apps/VPN and after this for WLAN.
I havent’t more options to import a certificate
In the picture you can see, that the certificate are been installed


#4

When you go to seahub using your browser does that work (using your mobile)?


#5

No that doesn’t work, with the Android 6 device too.
But i think Browser use their own certificate stores, don’t they?

edit: spelling corrected


#6

Possibly this could be the issue https://stackoverflow.com/a/47212691


#7

No it doesn’t.
I use already a certificate with the CA:TRUE Mark


#8

Did you solve the problem?
I have the same issue.

Any ideas how to enable Seafile Android to upload fotos with self-signed-certificated https Seafile server?

UPDATE:
I remebered, that it worked fine till middle of March.
Reinstalled former version 2.2.1 - and it works!

Question: where is the best place to tell Bugs?


#9

2.2.3 has several bugs. This one has already been reported numerous times. The Android Play Store is the official place to download the latest stable version, which is 2.2.1.