Server 6.0.7 web interface crash + shows only the first 100 files

EDIT: Please see my 3rd and 4th post below for updates on this.

Well, I’ll accept being called stupid if I’m missing something obvious, but I have about 335 files in the root folder of a library, and the web interface shows only the first 100. I can’t see a way to navigate to the rest. There seems to be some pagination going on. What am I missing?

Using Chrome v56 on Windows. Server is v6.0.7 on Ubuntu 16.04. The folder also has an upload and a download share links, both public.

I can see all files in the public download link, the client’s Cloud File Browser, and they are also synced just fine on my local machine. It’s just the web version when I’m logged in to the cloud using my account that has the issue.

Interestingly, I rebooted the server and now it works … javascript now kicks in when scrolling down and adds more files to the listing. I have no explanation for what caused the previous issue.

Ok, I think I managed to reproduce it. SOmone used the upload link to upload files using a browser. I got a notification in my Windows Seafile sync client about the uploads and i clicked “View unread notifications” in the client’s tray icon. It opened thre webpage with the notifications.

As soon as it did that, the web gui for the library started showing only the first 100 files.

It’s doing this only for that library. I tried other libraries where I have more than 100 files and the web gui works fine there (I can see Javascript kicking in and displaying chunks of 100 fiels as I keep scrolling).

I also tried a new session (private browsing) to get rid of all cookies and it still does the same thing for that library only.

I can’t restart the service on the server as someone is uploading. Any other ideas?

Ok, it got serious … I clicked on “Show all notifications” link in the web gui. there were 400 of them. When I clicked, the server responded with:

Page unavailable

Sorry, but the requested page is unavailable due to a server hiccup.

Our engineers have been notified, so check back later.

… and then the whole Seafile service became unresponsive and none of the clients could see the Seafile service any more. All web gui was dead too. Checking on the server, i could see the service is still running and listening on the right ports.

After about 3 minutes it came back up, but it still only shows the first 100 files in that library. I then tried to go back to show all notifications in the web gui, this time there were only 42 notifications. I got to see them but when I clicked “Clear” I got the same error message as above.

None of the logs show anything. In fact, none of the logs except ccnet.log show any log entries within the last 10 minutes when this happend.

ccnet.log entried for the last 1+ hours:

[01/06/17 16:23:30] ../common/session.c(398): Accepted a local client
[01/06/17 16:23:31] ../common/peer.c(943): Local peer down
[01/06/17 16:39:36] ../common/session.c(398): Accepted a local client
[01/06/17 16:39:36] ../common/peer.c(943): Local peer down
[01/06/17 17:19:32] ../common/session.c(398): Accepted a local client
[01/06/17 17:19:32] ../common/peer.c(943): Local peer down
[01/06/17 17:40:59] ../common/session.c(398): Accepted a local client
[01/06/17 17:40:59] ../common/peer.c(943): Local peer down
[01/06/17 17:45:43] ../common/session.c(398): Accepted a local client
[01/06/17 17:45:53] ../common/session.c(398): Accepted a local client
[01/06/17 17:47:21] ../common/peer.c(943): Local peer down
[01/06/17 17:47:42] ../common/peer.c(943): Local peer down
[01/06/17 17:48:44] ../common/session.c(398): Accepted a local client
[01/06/17 17:48:44] ../common/session.c(398): Accepted a local client
[01/06/17 17:48:44] ../common/peer.c(943): Local peer down
[01/06/17 17:48:44] ../common/peer.c(943): Local peer down
[01/06/17 17:48:44] ../common/session.c(398): Accepted a local client
[01/06/17 17:48:44] ../common/peer.c(943): Local peer down
[01/06/17 17:48:45] ../common/session.c(398): Accepted a local client
[01/06/17 17:48:45] ../common/peer.c(943): Local peer down

I’m using SQLite. I was previously using Seafile Pro but I reverted to Seafile CE. I did a migration from Pro v5.1.11 to CE v5.1.4 and then to CE v6.0.7 … all using the advertised procedure in the manual, which seemed to work.

My config files are

# cat /seafile/server/conf/ccnet.conf
[General]
USER_NAME = onex
ID = 29b7e22c5edc7182bf5784fe2ed20afa1f81c23f
NAME = onex
SERVICE_URL = https:/<my_host>

[Network]
PORT = 10001

[Client]
PORT = 13418
# cat /seafile/server/conf/seafile.conf
[network]
port=12001

[fileserver]
port=8082
# cat /seafile/server/conf/seahub_settings.py
SECRET_KEY = "<LONG_KEY>"
FILE_SERVER_ROOT = 'https://<my_host>/seafhttp'
EMAIL_USE_TLS = False
EMAIL_HOST = '<mailer_host>'        # smpt server
EMAIL_HOST_USER = '<my_email>'    # username and domain
EMAIL_HOST_PASSWORD = ''    # password
EMAIL_PORT = 25
DEFAULT_FROM_EMAIL = EMAIL_HOST_USER
SERVER_EMAIL = EMAIL_HOST_USER
# Replace default from email with user's email or not, defaults to ``False``
REPLACE_FROM_EMAIL = True
# Set reply-to header to user's email or not, defaults to ``False``. For details,
# please refer to http://www.w3.org/Protocols/rfc822/
ADD_REPLY_TO_HEADER = True

Any clues?