Server 8.0.3 docker - letsencrypt error

I’m using server version 8.0.3 in docker and I’m having issues setting up letsencrypt. I’ve set SEAFILE_SERVER_LETSENCRYPT to true and SEAFILE_SERVER_HOSTNAME to my server address (say myserver.duckdns.0rg).
I have forwarded port 443 in my router to my server. The container also has port 443 published. However, I get this error:

*** Running /etc/my_init.d/01_create_data_links.sh...,
*** Booting runit daemon...,
*** Runit started as PID 24,
*** Running /scripts/start.py...,
fatal: unable to connect to github.c0m:,
github.c0m[0: 140.82.121.4]: errno=Connection timed out,
,
[2021-02-27 23:47:12] Preparing for letsencrypt ...,
[2021-02-27 23:47:12] Starting letsencrypt verification,
Traceback (most recent call last):,
  File "/scripts/start.py", line 86, in <module>,
    main(),
  File "/scripts/start.py", line 51, in main,
    init_letsencrypt(),
  File "/scripts/bootstrap.py", line 71, in init_letsencrypt,
    call('/scripts/ssl.sh {0} {1}'.format(ssl_dir, domain)),
  File "/scripts/utils/__init__.py", line 70, in call,
    return subprocess.check_call(*a, **kw),
  File "/usr/lib/python3.6/subprocess.py", line 311, in check_call,
    raise CalledProcessError(retcode, cmd),
subprocess.CalledProcessError: Command '/scripts/ssl.sh /shared/ssl myserver.duckdns.0rg' returned non-zero exit status 1.,
*** /scripts/start.py exited with status 1.,
*** Shutting down runit daemon (PID 24)...,
*** Running /etc/my_init.post_shutdown.d/10_syslog-ng.shutdown...,
*** Killing all processes...,

Is there any other setting that I’m missing? I’ve previously run certbot directly on my server (with nextcloud) and I had no issues setting it up, so it must be something related to docker or seafile itself.
PS: .0rg and .c0m are there because I get an error for posting links