Size too large - changes in ccnet and seafile.conf without effect

Hi All,

running the 8.0.7 of the pi/debian buser: [seafile-server-8.0.7-buster-armv7l.tar.gz]
before i run 8.0.5 and had the “zip” bug, which is now solved.
But the “size is too large” issue i’m not able to solve.

I can see there is a change from 7 to 8 where the fileserver config was moved from ccnet to seafile.conf, but when i enter “[filerserver]” the syntax check of my nginx is telling me and error.
When i enter max_download_dir_size=2000 at ccnet or seafile.config the error with the size limit still exists.

What am i doing wrong ?

Thank you for helping me.


“[filerserver]” has extra “r”. Should by “[fileserver]”. You shoud use seafile.conf and not seafile.config. Then restart seafserver seafhub.


HI Mirac,

just tried the it but the nginx snytax check is returning me an error.
nginx: [emerg] unknown directive “[fileserver]” in /etc/nginx/sites-enabled/seafile.conf:83
First it will tell me there is no end sign when using “max_download_dir_size=2000” which i have to correc to “max_download_dir_size=2000;”
After that nginx will return that the directive is unknow.
Further when i enter same in ccnet.conf no syntax error but no effect either with [fileserver].
What strange is, that the all the entries i’ve searched telling me to put it into the seafile.conf, but the structure is more matching with ccnet instead of seafile.
I’m doing something wrong ?

Thanks for helping me.


You edit the nginx config file. You should edit the config file for the seaf server component of Seafile.

Both are - usually - called seafile.conf. But the former is in /etc/nginx/sites-available and the latter in /opt/seafile/conf (or /whateveryourinstallpath/conf)

Hero of the day !!!
Thank you for the hint. Changed the seafile.conf file at the install path and it worked !

Thank you !