[SOLVED] All Repo's / Commit's missing after Update from 7.0.5 to 7.1.4

Hello TEAM,

i have a Problem updating Seafile Server CE from 7.0.5 to 7.1.4.

At first, everything seemed to be fine. Later, I just wanted to access some files on the Server after i did the Update yesterday.

Seafile Client then reports “Folder “/” is Deleted”. No matter what account or Library i tried to access.
Login to Seahub shows the same behavior. I can see all Libraries but no files or folders inside the Libraries.

Iam Running:

Raspi 4
Debian Buster Kernel 4.19.97
seaf-data is on an cifs share
nginx 1.14.2
mariadb 10.3.22
python 3.7

i have the following nginx conf for seafile:

   location /seafile {
            proxy_pass    ;
            proxy_set_header        Host $host;
            proxy_set_header        X-Real-IP $remote_addr;
            proxy_set_header        X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header        X-Forwarded-Host $server_name;
            proxy_set_header        X-Forwarded-Proto https;
            proxy_connect_timeout   36000s;
            proxy_read_timeout      36000s;
            proxy_send_timeout      36000s;
            proxy_http_version      1.1;
            proxy_set_header        Connection "";
            proxy_set_header        X-Forwarded-Proto $scheme;
            # used for view/edit office file via Office Online Server
            client_max_body_size    0;
            proxy_request_buffering off;

            access_log      /var/log/nginx/seahub.access.log;
            error_log       /var/log/nginx/seahub.error.log;

    location /seafhttp {
            rewrite ^/seafhttp(.*)$ $1 break;
            proxy_pass    ;
            proxy_set_header        X-Forwarded-For $proxy_add_x_forwarded_for;
            client_max_body_size    0;
            proxy_connect_timeout   36000s;
            proxy_read_timeout      36000s;
            proxy_send_timeout      36000s;
            proxy_request_buffering off;

    location /seafmedia {
            rewrite ^/seafmedia(.*)$ /media$1 break;
            proxy_connect_timeout   36000s;
            proxy_read_timeout      36000s;
            proxy_send_timeout      36000s;
            proxy_request_buffering off;
            root /home/seafile/seafile-server-latest/seahub;

any help would be appreciated.

regards in advance


Running Seaf-fsck.sh gives me:

[07/22/20 16:16:30] fsck.c(590): Running fsck for repo beea0af8-86c9-4c03-8e81-2ac3d058e9d7.
[07/22/20 16:16:30] repo-mgr.c(296): Commit a701b2324758a5332a95df3fc0c7b404d8059b06 is missing
[07/22/20 16:16:30] fsck.c(607): Repo beea0af8 HEAD commit is damaged, need to restore to an old version.
[07/22/20 16:16:30] fsck.c(501): Scanning available commits…
[07/22/20 16:16:30] fsck.c(508): No available commits for repo beea0af8, can’t be repaired.
[07/22/20 16:16:30] fsck.c(654): Fsck finished for repo beea0af8.

However: The File:

/srv/VOLUME_01/CLOUD/seafile-data/storage/commits/beea0af8-86c9-4c03-8e81-2ac3d058e9d7/a7/01b2324758a5332a95df3fc0c7b404d8059b06 is 575 Bytes in Size and accessable


Running seaf-fsck.sh in /seafile-server-7.1.4/ leads to the above behavior. Running seaf-fsck.sh in /seafile-server-7.0.5/ has a normal behavior. Takes hours, No Errors.

Sounds like seafile can‘t find the data folder. Setting custom path to data folder is not supported anymore: [SOLVED] New install with mariadb/mysql and 2nd drive; How to move data location?

@Simsala You are my Hero of the day!

ln -s /srv/VOLUME_01/CLOUD/seafile-data /home/seafile/

Did the trick.

1 Like