Solved: Cannot add any account on android client

I want to add a new account (other Seafile-server). All entries correct and server working. Whenever I push ‘sign in’ I ll come back to the start activity (Wellcome / add account).
So I am not able to access my cloud.

System Informations:
Galaxy A5, lineageos 14.1.

When the system was blank installed, everything went right. Later on I was not able to access the saved account.

What I tried:

  • stop/restart client
  • clear cache, clear data
  • uninstall - reboot phone - reinstall
  • change memory location (intern->extern, extern->intern)
  • format sd-card (as intern, as extern, then reinstall seafile-client both times)
  • reinstall the whole system -> same behavior: worked fine till first reboot.

Now I have no ideas, what I can do? Any suggestions?
Are there any logs? How I ll get them?

Thanks for every hint!

Update | Workaround
I made a build via actual gitHub code with android studio.
Everything works fine - but only with the debug-build-version.
A release-version have had the same issue.

Does your server have a valid SSL certificate installed?

Possibly certificate validation is disabled in debug builds, but enabled in production builds / releases.

Hello shoeper,
thx for your hint.
Not a ssl-error.
I solved it. Was an phone-error. Got problems with other apps, too.
Wiping everthing an repair/reformat partitions on the device an reinstall everything solved it.

See also [SOLVED] Android App: Account Disappears
This seems to be an android issue and it will come back if the application is moved to the SD card (even if formatted as internal storage).