SOLVED: Delete acepted Certificate

Hi

My client raised the concern that the certificates don’t match.
I accidently did “don’t ask again” and then chose “yes”.

Now the seafile client can’t connect anymore because of certificate issues.

Deleting the account and adding it again doesn’t help. It seems to remember a wrong setting somehow.

How can I reset the accidently accepted certificate that accidentally accepted setting?

Chris

What do you mean by “can’t connect anymore”?

If you did “don’t ask again” and then chose “yes”., it should always accept the server certificate. So I don’t understand why your client can’t connect anymore.

Can you check the log file seafile-applet.log?

Thanks so much for answering my post.
That is really very much appreciated and always so helpful.

Indeed there is an issue that confuses me.

from applet.log I can see:
[11/24/16 09:08:35][api] network error for https://seafile.example.com/api2/repos/: Host seafile.example.com not found
[11/24/16 09:09:12][api] network error for https://seafile.example.com/api2/ping/: Host seafile.example.com not found

But I can access seafile.example.com via a browser and I can ping it.
Might it be a permission thing again for the /api/ping ?

In seafile.log from osx client i get:
[11/25/16 08:31:33] http-tx-mgr.c(707): libcurl failed to GET https://seafile.example.com/seafhttp/protocol-version: Peer certificate cannot be authenticated with given CA certificates.

I have a letsencrypt certificate. In google chrome it’s “green”, when I browse to seafile.example.com.
Could it be a permission issue on the certificates?

HI

As I said I use a letsnecrypt certificate and had to refer in te gninx conf to the “fullchain.pem” certificate but I did refer to the "chain.pem"certificate.
That seems to have solved the certificate issue. the seafile client is now connecting again as normal.

Thanks for pointing me into the right direction. That was really helpful.