(solved) Elasticsearch on 9.0.3 Pro still not working

Upgraded to today to 9.0.3. Removed old docker of Elasticsearch 6.*. Installed as per server manual version 7.16.2 and followed again the install guide. Deleted all indexes.
When running “pro.py search --update” getting the same error messages and repeated few times. Summary looks like this: (last few lines after 200+ of the same error messages)
File “/opt/seafile/seafile-pro-server-9.0.3/pro/python/seafes/repo_data/init.py”, line 16, in to_dict
for i in result_proxy.mappings():
AttributeError: ‘ResultProxy’ object has no attribute ‘mappings’
01/03/2022 13:12:24 [INFO] seafes:124 thread_task: worker0 worker get 15 error
01/03/2022 13:12:24 [DEBUG] seafes:94 thread_task: Queue is empty, worker1 worker threads stop
01/03/2022 13:12:24 [INFO] seafes:119 thread_task: worker1 worker updated at 2022-01-03 13:12 time
01/03/2022 13:12:24 [INFO] seafes:124 thread_task: worker1 worker get 16 error
01/03/2022 13:12:24 [INFO] seafes:38 clear_worker: All worker threads has stopped.
01/03/2022 13:12:24 [INFO] seafes:72 run: index updated, total time 2.062624454498291 seconds
01/03/2022 13:12:24 [INFO] seafes:131 clear_deleted_repo: start to clear deleted repo
01/03/2022 13:12:24 [INFO] seafes:135 clear_deleted_repo: 0 repos need to be deleted.
01/03/2022 13:12:24 [INFO] seafes:139 clear_deleted_repo: deleted repo has been cleared
01/03/2022 13:12:24 [INFO] seafes:164 start_index_local:

Index updated, statistic report:

01/03/2022 13:12:24 [INFO] seafes:165 start_index_local: [commit read] 16
01/03/2022 13:12:24 [INFO] seafes:166 start_index_local: [dir read] 0
01/03/2022 13:12:24 [INFO] seafes:167 start_index_local: [file read] 0
01/03/2022 13:12:24 [INFO] seafes:168 start_index_local: [block read] 0

This is your SQLAlchemy version problem. You need to upgrade it to version 1.4.x.

I had version 1.4.3. Upgraded to version 1.4.29.
Still the same error :frowning:

Maybe you should install SQLAlchemy using root user.

Uninstalled and installed again as root. Error remains same.
Python shows as 3.9.7, SQLAlchemy as 1.4.29

I had the same problem. In the end, i installed ALL pip requirements in both users, root and seafile. This helped and is now working.

i tried it both ways, only root and only in the seafile user. Neither worked.

YES! That did the trick! Now works on my side as well.

what are all pip requirements? and are they needed if using the docker installation of seafile pro?