[SOLVED] Fail2Ban not working

Hi

I’m trying to get F2B working on Pro v6.2.10.

fail2ban-regex shows several hundred hits and fail2ban-client shows the jail so I’m confident that I’ve got the F2B files correct - just cut and paste from the manual. I’ve also added a TIME_ZONE line. But despite everything, I have nothing in the jail. I’ve checked all the ownerships and permissions and they seem fine too.

My seahub_settings.py file is

# -*- coding: utf-8 -*-
SECRET_KEY = "<it's a secret>"

DATABASES = {
    'default': {
        'ENGINE': 'django.db.backends.mysql',
        'NAME': 'seahub-db',
        'USER': 'seafile',
        'PASSWORD': '<secret>',
        'HOST': '127.0.0.1',
        'PORT': '3306'
    }
}

TIME_ZONE = 'Europe/London'

Any idea what I’ve missed?

Can you post your fail2ban config?

I had the same problem before, failban does not block IP of incorrect logins but I narrowed it down because the LOGIN_ATTEMPT_LIMIT is not set.

LOGIN_ATTEMPT_LIMIT = 3

1 Like

This wasn’t my issue.

I was being stupid - I was testing from my workhorse laptop and I had added that IP address to the ignoreip setting in jail.conf so I could never lock myself out!!

But it was your prompting to look for the LOGIN_ATTEMPT_LIMIT setting which caused me to spot my mistake, so I am very grateful. Thank you.

Marked solved