SOLVED: No file upload on Windows Server with URL Rewrite as Reverse Proxy

android

#1

I have a Seafile server running on Windows Server 2012 R2 machine via SSL, everything works, i have made sure to closely follow the tutorials etc. the https runs on a custom port. I tried to forward and open all the other ports aswell, no luck.

The only thing that does not work are the mobile clients, website UL/DL works fine, even on mobile! But the clients just wont work. I can browse the files, but cant interact with them via both mobile clients.

Any help appreciated.

edit:
I am using a custom port for the seahub component, but again, it works no problems on desktop and website…


#2

Ok i think i may have found the cause of this.

When i try to share the file (via website on desktop), it will generate link with localhost in the url.
The thing is, i have already changed the service url in ccnet.conf from localhost to external IP but it still says localhost (even after restart).


#3

You have to change this in your databases ccnet config. You can do this in the Web Interface under Admindistration -> Preferences.


#4

Thanks for the reply.

Now i can download shared files with correct URL.

But still cant UP/DOWN within mobile app :confused:


#5

But with the Web Interface it’s working ?? Do you have any kind of reverse proxy running?


#6

Yes i have reverse proxy running on the Windows Server, its called URL Rewrite.

Its supposed to redirect all urls to https and then all seafhttp urls to ocrrect seafhttp url


#7

You can download from the WebUI or can’t you?


#8

Yes yes i can. I can download from WebUI using mobile too (entering url in mobile browser).
Only problem are the mobile clients, i can see the files but cant download.


#9

Uploading on the web interface doesn’t work, too. So it seems you’re configuration is wrong. If you don’t have a lot of experience with FastCGI or WSGI I would use one of the recommend reverse proxies, nginx or Apache. But if you post your config of UrlRewrite maybe I can find the issue.

Another question: Since when SeaFile on Windows supports Markdown? I thought it’s still version 6.0.7?


#10

#11

I just found out that Upload doesnt work via web interface either. But download via web is ok.

Summary:
Web interface: Down ok; UP not working
Mobile clients: DOWN/UP not working


#12

Hi here

web up/down - ok
app down ok
app up - not working


#13

Also on Windows Server ? Else please open another thread.

He can’t download on the App, so it’s not related.


#14

Regarding Android app uploading see if this help. It solved it for me.


#15

I tried to install earlier version but Upload still failing. Its a connection problem i think rather than app


#16

UPDATE: It’s working now! Solution below.

Cause: My retardation
Solution: In web interface, under System admin, under Settings, make sure you also put your custom port behind your IP! It turns out i didnt and totally missed it :confused:

Oh well.

Only problem right now is i cant upload via Android app (iphone works), but i will test the previous version as said above and will report back.

EDIT: Android app Upload works with app version 2.2.1, but newer doesnt work.