SOLVED: Seafile-CLI: ImportError: No module named ccnet


I am not getting the Seafile-CLI running on an ARM board.

Basing the installtion on the 6.1.7 client.

After doing the installtion according to the manual, i get the error that ccnet module does not exist (see below).

What could I do to solve this?
This cost all my easter weekend :wink:

seafile@helios4:~$ seaf-cli init -d ~/.seafile-client
Traceback (most recent call last):
File “/home/seafile/bin/seaf-cli”, line 95, in
import ccnet
ImportError: No module named ccnet

I used the typical installation in the /usr folder.

That worked.

You beat me to it… I noticed that you said you are using ARM. ARM installations use 3 or 4 different folders (/usr, /opt, /var, and a seafile folder) upon install whereas the Linux version of Seafile uses only one.

@shoeper - Another one we can mark as solved.

Sorry for the silly question, but what do you mean by:

I’m following the located at and would expect that following the official docs would account for the requirements to avoid this error. :slight_smile:

In my case I am running on Ubuntu 18.04 and installed via the seafile clients PPA.

Thank you in advance for the clarification.


I don’t really remember. Are you running the Ubuntu 18 on an ARM board?