[Solved] Seafile Client 6.1.x Adding Server

I have noticed on all my desktop sync client’s that there has been a “” server added. I have looked in the config files and can find nothing to reference localhost. The server is NOT local and works fine from its proper host. This happened on the 6.0.x client and also now with the 6.1.x client. Would be nice to get to the bottom of this, can never tell when there is an actual connection issue with the real server as (!) always shows in the notification icon. This happens on both the Windows and Linux clients.


Can you check the account list by clicking the avatar?

It just lists the one .cloud account, nothing else.

This was already introduced with 6.0.7. - and reported here. However nobody was able to tell why this happens or even provide a fix.

I am well aware of the other topic with similar issue, but I am having issues with the windows client AND linux client, that thread indicates windows only, so it does not totally apply to what I am having an issue with, hence… new topic.

After analysing the source code, we think the problem caused by that the server doesn’t have correctly set the SERVICE_URL and FILE_SERVER_ROOT. Can you check it?

The default SERVICE_URL is

All set correctly…

Checked my as well. The similarity: I’m as well using secure connections: “https://sea.x.z…”. No http. So maybe the client will check http?

This wouldn’t really be an issue in my setup. Nginx is doing a 301 permanent redirect with HSTS. This also never use to be a problem and the only things changing is the seafile server versions and client versions.

I seem to have found the issue after doing some digging. It appears I had removed the proxy_set_header X-Forwarded-For $remote_addr; accidentally from the nginx site config, Adding this option back in has removed the from the clients and only show the correct server now.


HI all,

I think i found the issue on Apache

ProxyPreserveHost On


I do not have anymore on my seafile client



1 Like

Anybody an idea what this configuration would look like for IIS? Which variable would it be?
It’s for sure the same issue, I see the 127… only if I access from remote. Locally it’s not showing the 127…

Just wanna say thanks, it works like a charm ! It also corrected an issue where the email registration would read “registration from”. xD

Thanks again. :slight_smile:

1 Like