[SOLVED] Seahub (Seafile website) looks garbled after running a minor upgrade

Hi,
After running ./upgrade/minor-upgrade.sh on my Seafile server the website (Seahub?) suddenly looks all garbled. What happened and how can it be undone?

Running Seafile server 6.0.10 under Nginx 1.12 on Arch Linux ARM.

Check seafile folder chmod. (your webserver can read the folder, and files inside the folder?)

:slight_smile:
NKelemen

It doesn’t look like the folder (or file) permissions have changed. The user running Nginx should have reading permissions to the Seahub files, just like it had before. Looks like FreeCloud is having a similar problem.
How should the correct file permissions look like? Does the web server require reading permissions or both reading and writing (for the Seahub folder)?

EDIT:
I uninstalled all packages related to Seafile and recompiled and reinstalled them. Now Seahub is displaying its pages correctly! Thank you kindly for your help.

FreeCloud: I hope this solution will work for you as well. This thread can be marked as solved.

Now, I hope that the sync error with a crashing seaf-daemon that arose from the last update can be resolved…