[solved] Upload stops in WebGUI for large files

Hi Community,

I faced a nasty problem with uploading large files using the WebGUI. As I could not find the problem described but managed to solve it, I think I should post the solution here.

My setup is Seafile CE 8.03 on a Raspberry Pi4 using Raspbian Buster and Nginx.

The Problem
The upload using WebGUI sometimes came to a sudden stop. The WebGui would just halt a certain percentage without continuing. Neither the logs of Nginx nor Seafile or Seahub would show any useful information. Only some “leaked connections” of Nginx were to be found in the log.
Sometimes the nginx seafhttp.error.log would show a broken pipe for that point in time.

Ultimately I managed to find the issue and fix it. The reason was a default-timeout for web tokens for the WebGUI. When the upload took longer than one hour, the timeout kicked in, accidentially crashing a pipe and stopping the upload. Unfortunately this is not reported in the WebGUI.
Uploading with a small bandwidth can easily lead to upload times beyond one hour.

The Solution
BY default, the timeout is set to 3600 seconds, i.e. 1 hour. By adjusting this in the Seafile configuration this can be changed.

In order to do so, the Parameter web_token_expire_time needs be set to a different value in configuration file seafile.conf.

This is my current and working configuration file seafine.conf:

host =
port = 8082

worker_threads = 15
max_indexing_threads = 10

#Set uploading time limit to 36000s

Hope this is a help for someone :slight_smile:

1 Like