Strong user password

I’ve enabled the user sign up option.
Further the password settings are set to strong and level 3 with a minimum length of 6.
I’ve a test e-mail user and I’m trying to sign up. However I cannot generate a password that is strong enough!
Disabling the strong password settings - it works!
I’m running Seafile 6.0.9 on Ubuntu 16 LTS
I’ve other users connected via LDAP (Active DIrectory).
Anyone else having same issue?