Stuck at “Downloading files… 0%”

The following issue affects the Seafile client 5.1.1 and 5.1.3:
After initiating syncing an existing library (library was synced before, but had been unsynced for several months) with an existing folder, the status for this library becomes stuck at “Downloading files… 0%”. The seafdaemon process fully utilizes one thread (resulting in a constant 25% CPU usage on a system with 4 cores). Trying to cancel the process will result in displaying “Canceling” in the seafile applet, but will not actually cancel anything, when restarting the client, the status reverts to “Downloading files… 0%”. The library is roughly 30GB in size. I waited around 1 hour for the status to change, but it didn’t (so far).

The following can be found in the seafile.log (after a client restart):

[07/24/16 23:21:41] clone-mgr.c(819): Transition clone state for from [init] to [connect].
[07/24/16 23:21:41] clone-mgr.c(819): Transition clone state for from [connect] to [fetch].
[07/24/16 23:21:41] http-tx-mgr.c(4130): Download with HTTP sync protocol version 1.
[07/24/16 23:21:41] http-tx-mgr.c(1012): Transfer repo ‘’: (‘normal’, ‘init’) --> (‘normal’, ‘check’)
[07/24/16 23:21:41] http-tx-mgr.c(1012): Transfer repo ‘’: (‘normal’, ‘check’) --> (‘normal’, ‘commit’)
[07/24/16 23:21:41] http-tx-mgr.c(1012): Transfer repo ‘’: (‘normal’, ‘commit’) --> (‘normal’, ‘fs’)
[07/24/16 23:21:43] http-tx-mgr.c(1012): Transfer repo ‘’: (‘normal’, ‘fs’) --> (‘normal’, ‘data’)

Do you have any idea on how to fix this issue? Is it possible to delete the temporary data of the library (canceling the process manually) and try to start syncing it again? Any help would be appreciated!

Note: I copied this thread from the .de community forum.


How many files do you have in that library? It’s very likely that the client is comparing every file’s time stamp with the ones from the cloud.

You can set “SEAFILE_DEBUG=all” env variable to let the client print verbose log. That may reveal more details.

1 Like

At first, I thought so too, but monitoring my system I detected no disk or network access during the whole time of the “Downloading files… 0%" status. The library has around 35.000 files. I will enable the debug log and report back, thanks for the suggestion!

Having the debug log enabled, I could see the output wt and index are consistent. no need to checkout. repeating in the log file. I guess it was recorded for nearly each file there was in the library, so it seems like Seafile indeed compared the metadata for each file during the entire time! This time, the process finished in just under one hour and the status changed to synchronized (with conflicts, not sure why, but that’s no big deal) - seems like I did not wait long enough the last time I tried. I am still not sure why no disk activity was monitored during the process - maybe the disk’s MFT was cached?

However, I highly recommend improving the status display. It is not helpful having the status “Downloading files… 0%” displayed for one hour, which then abruptly changes to 100%. It makes one wonder whether Seafile is working correctly.
Making the overall process more efficient (reduce time and CPU usage) would also be great, though I can understand if that is not a priority right now. Just a thing for the wishlist :slight_smile:

Thank you for the help!

1 Like

So which forum gave you the information you needed? .com or .de…

Jonathan’s hint was the more helpful one - so the .com forum.

1 Like

So the actual developers of the software trump, seem only logical this would be the case. @Jonathan

Yes we’ll improve the progress for this situation. Glad it worked out :wink:

I’m using Seafile Pro version 9.0.16, how can I set “SEAFILE_DEBUG=all” env variable to let the client print verbose log? I have same error with a library, can not Cancelling Sync.