Suddenly... 502 Bad Gateway

I had a full working Seafile installation via Docker, the latest version was installed 2 months 9.0.4 and it was working perfectly until 2 days ago.
I hadn’t changed anything.
Suddenly it reports 502 bat gateway.

that’s the docker-compose.yml

version: '2.0'
services:
  db:
image: mariadb:10.1
container_name: seafile-mysql
environment:
  - MYSQL_ROOT_PASSWORD=________________  # Requested, set the root's password of MySQL service.
  - MYSQL_LOG_CONSOLE=true
volumes:
  - /opt/seafile-mysql/db:/var/lib/mysql  # Requested, specifies the path to MySQL data persistent store.
networks:
  - seafile-net

  memcached:
image: memcached:1.5.6
container_name: seafile-memcached
entrypoint: memcached -m 256
networks:
  - seafile-net

  seafile:
image: seafileltd/seafile-mc:9.0.4 #seafileltd/seafile-mc:latest
container_name: seafile
ports:
  - "80:80"
  - "443:443"  # If https is enabled, cancel the comment.
volumes:
  - /mnt/HC_Volume_8415635/opt/seafile-data:/shared   # Requested, specifies the path to Seafile data persistent store.
environment:
  - DB_HOST=db
  - DB_ROOT_PASSWD=________________  # Requested, the value shuold be root's password of MySQL service.
  - TIME_ZONE=Etc/UTC  # Optional, default is UTC. Should be uncomment and set to your local time zone.
  - SEAFILE_ADMIN_EMAIL=snipershady@gmail.com # Specifies Seafile admin user, default is 'me@example.com'.
  - SEAFILE_ADMIN_PASSWORD=________________     # Specifies Seafile admin password, default is 'asecret'.
  - SEAFILE_SERVER_LETSENCRYPT=true   # Whether to use https or not.
  - SEAFILE_SERVER_HOSTNAME=cloud.mydomain________________.it # Specifies your host name if https is enabled.
depends_on:
  - db
  - memcached
networks:
  - seafile-net

networks:
  seafile-net:

The problem is caused by Let’s Encrypt
as I’ve posted here.

waiting for an official solution