Sync interval in seafile linux client

We’re trying to set the sync interval in the seafile linux client. Our problem is that a folder is only synced every few minutes when changed are made by another client and we want it to be immediate.

We tried using the method described here in the forums to set the sync interval in the repo.db:
INSERT INTO “RepoProperty” VALUES(’$REPOID’,‘sync-interval’,’$SECONDS’);

Setting the sync interval in this database doesn’t seem to have any effect though. Is there another way to set the sync interval?

Setting a sync interval will break immediate sync. Make sure the fs supports inotify. Also make sure fs.inotify.max_user_watches is large enough (in sysctl.conf).