Sync problem with Android mobile app (rollback)


we use Seafile to sync Excel files between several mobile and desktop clients. We do this for over 2 years now, without greater problems. Since about 3 weeks we have a problem with the mobile clients:

  1. The user opens the excel sheet in seafile with “documents to go” (office app), fills in data, saves the file.
  2. Some minutes later he fills in more Data and saves the file.
  3. Hours later he edits the file again and saves it.

All 3 steps at the same location with good LTE connection. In the evening, I open up the file on Seafile desktop client and I only see the data of step 1. The data of step 2 and 3 has disappeared, also on the mobile client. I also can’t find the data of step 2 or 3 in the Seafile Snapshots, which suggests that the app has not uploaded anything. Up to now this happened 3 times (2 different users and Android- devices).

Server: Windows Server v6.0.7. 11 Users. Total data is less than 15GB. The main sync folder with the excel sheets has a size of about 500MB and we use a subfolder where just the files, that are in process, are stored (usually < 2MB).
Database: MySQL 5.1.73
Desktop Clients: Different Versions 6.0+
Mobile Clients: v2.1.13

What have I tried to solve the Problem:
• Updated Server from 5.1.3 to 6.0.7
• Updated Python to 2.7.13
• Run gc.bat
• Run seaf-fsck

Additional information:
Short before the problem appears for the first time, I added a new user (No. 11). But this user does not yet work actively with Seafile and has no access to the affected folder.
Apart from the problem mentioned, the server runs very good and fast.

Is this a known issue? Has anybody the same problem? Is there may be a problem with the Seafile Server for Windows? Is it a mobile app problem?

I hope someone has an idea. Thank you in advance!


Hi again,

today I had the problem again and I could analyze it a bit more. Here is what I found out…
It is no connection problem. I can replicate the problem with Wifi connection.

In my case only one file is affected. There are 15 files in the folder right now, and I can modify every file and it get synchronized correctly, except one file. The files are all identical Excel templates and differ only by the file name and contents of the tables. If I copy the file, which has sync problems, the new file gets synced without problems.

In the Seafile app you can see the filename and beneath it, you can see the file size and also a time stamp that shows when the file was modified for the last time. If u modify a file in the app, save it and go back into the seafile app, you usually get a short popup: “updated filename” (deutsch: “Aktualisiert Dateiname”) and the time stamp gets updated. That doesn’t happen to the affected file.

You can open and save the file again, but the timestamp gets no update and no popup appears. As long as you open the file with the same Android device, it contains the correct data, but it doesn’t get synced with the server. If you now open the file with another device (in my case a desktop client), the data is lost (also on the Android client) and the file now contains the data that it had, at the time of the old timestamp that is displayed (rollback).

If I modify an affected file and rename it in the seafile mobile app, it gets synced containing the “old time stamp data” (rollback).

After much trial and error and some breaks, the seafile android app synced the data of the affected file. Some minutes later I added Data to a table, saved the file and again it doesn’t get synced.


Thank you for the detailed report.

Can you try with the version Android client 2.1.11,?
You can download all versions here:
I want to make sure it is not caused by a bug with a modification in version 2.1.13.

Maybe it is not necessary to test version 2.1.11. If the release date of version 2.1.13 (03.06.2017) in github is correct and matches with the release date in google play store, I can ensure you that the problem already existed before v2.1.13. I recognized the problem for the first time on 24.05.2017, the second time was around 07.06.2017, then again on 12.06.2017 and 13.06.2017.

Is this information sufficient? If you need further assistance, please let me know.

Additional information: On my device I have Android version 6.0.1.

No problems with v2.1.11 up to now.

Still no problems with v2.1.11. It is very obvious that the problem exists from version 2.1.12 onwards.

Have you already located the problem? When will you fix it?

still problems with version 2.1.13. Version 2.1.11 works fine.

I had this problem when i install a spy recorder to my phone on Android…

Okay, we will look into the problem.

Thanks for the information.
I don’t use a app like this, i just have the Biddefender mobile security app, that has an Anti-Theft function. And I already used it before the problem occurred. The other thing is, that we have the problem on several devices, and there is no spy recorder app installed either.

We have add a possible fix. Please try version 2.1.14 :

Thanks for the fix, but there are still problems.

  1. On my Samsung Galaxy Note 2014 Edition with Android v5.1.1 it seems to work fine, but I have not tested it long enough to say that the bug is fixed.

  2. On my Samsung Galaxy A5 with Android v7.0 the problem has become even worse. Now it is not possible to edit the file and save it into the “seafile- sync- file”. Let me explain…usually you open a Excel file, edit it and save it (not “save as”) and seafile syncs it automatically. Now, with v2.1.14, you open a file, edit it and save it and a window pops up where you have to enter a local destination to save the file (just like the “save as”- function). So with version 2.1.14 it is not possible to use seafile as a sync folder for Excel files on a android v7.0 smartphone. I am using v2.1.11 again.