"This site can't be reached" for fresh seafile install

Hello !

I freshly installed seafile (SQLite) on my virtual server (host: aruba cloud).
I just installed it following the official instructions.

Installation was straightforward and I can start both seafile and seahub from my user (non-sudo) account :

XXXXXXX@MyNewPony:~/backups/seafile-server-6.2.5$ ./seahub.sh start

LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub at port 8000 …

Seahub is started

Done.

However, then I cannot access the server now. If I type in my brower :

https://XX.XX.XX.XX:8000

It takes a while in ‘setting up secure connection’ and then I get a “This site can’t bee reached. XX.XX.XX.XX took too long to respond”

I tried a couple ports and I always get the same…

Any pointer to what could be wrong ?

Which webserver are you using? NGinx, Apache, or something else? Have you taken a look at the webserver logs and seafile logs?

Hey, thanks for your answer !

I installed seafile with SQlite, following (I hope) :
https://manual.seafile.com/deploy/using_sqlite.html

But did you forget that you have to install a web server? If you forgot it, the easiest method to install seafile is with the official docker container,

Ha. Thank you for the kind way to ask the question (rather than “you are too stupid to think that you might need a web server”).

I don’t have a web server installed. I worked under the assumption that seahub was the server for the desktop client - and included a web server. Well it clearly doesn’t.

I’ve been hearing about docker a lot, but never used it. I’m not a sysadmin by any mean. Would that make sense to actually use docker ? I think I could manage to install - again - an apache server on my VPS and use it for seafile.

Yes, Seafile does have a rudimentary web server, in a way. However, since you are running it under Docker, you may have to install NGinx or Apache, or some other web server backend.

It will run fine the way you set it up as specified in the manual providing you install it on a Linux box.

Hey,

I am running it on a Debian, but not with docker yet. So seahub is a web server ? Then I don’t get where why problem comes from… I guess I’ll reinstall apache.

Hey,

So I opted against docker, mostly because my VPS uses a 32 bits distro.
I upgraded it to Debian 8.10 (Jessie), along with installing apache 2.4.

I now have a functional apache install that served /var/www/index.html to my browser on a distant computer

I followed https://manual.seafile.com/deploy/deploy_with_apache.html
to change /etc/apache2/sites-available/000-default.conf to add a proxy.

Now I go back to the original situation where the browser is endlessly waiting for connection…

The Container has nginx and MariaDB included, do I would do it and Docker is really easy to handle. But is it now working or not? And why do you use i686 Debian and not amd64 ? Or have you OpenVz and therefore no hypervisor?

Edit: You have an hypervisor, why did you this ? That’s a strange behaviour, and if you use more than one account, it’s always better to use MariaDB.

Can you post your Apache log file here when you try it again? Also, post your Seafile logs as well. It may also help to post your django log.

If you are using Apache, you won’t be using http://xxx.xxx.xxx.xxx:8000, though. Apache needs to be set up as a reverse proxy.

And, to answer your question… Yes, Seafile is kind of a web server and Apache/NGinx are not necessary to run it, but it is advisable to run NGinx or Apache.