Trying to setup on docker... can't get the webui to load?

I’ve set up using both the standard docker-compose setup, and the ggogol ‘containerised’ one, but in neither case could I actually get the webui to come up… and I’m not sure why. Nothing in the install or the logs (that I could find) showed any issues. Though in the ‘official’ setup I didn’t seem to end up with anything in the conf folder of nginx which… doesn’t seem right?

Things I’m not sure if I did them right (and aren’t really explained in any of the documentation that I saw) -


I assumed that the ones listed were placeholder ones, as generally docker volumes can be stored anywhere and only the links matter. So I used -


  • /volume2/docker/seafile/seafile-mysql/db:/var/lib/mysql


  • /volume2/docker/seafile/seafile-data:/shared

I have tried with letsencrypt off and on, neither helped. Though the official documentation says the hostname you enter will only be used with letsencrypt on… but doesn’t specify how you actually get to the webui when its off?

But regardless, the host name doesn’t work with letsencrypt on either. Am I meant to be setting up another section of nginx or something elsewhere? I use SWAG for my reverse proxying, but I assumed the official container took care of this for me for this case? No?

Totally confused at this point.
Hopefully someone can point out where I might have gone wrong haha.

pastebin /qaJ0vL9M - my compose file

pastebin G2r8ru0p - new attempt with compose file

Basically I just commented out 443, and hostname line, and turned off letsencrypt, and then changed the ports to 8282:80.

Now, it actually seems to install seafile properly, with conf folders and files in the seafile directory (definite progress) but ip:8282 still just goes to a “can’t reach” error.

Seafile log shows no obvious errors.
Maria log shows -
“2022-05-22 5:57:33 4 [Warning] Aborted connection 4 to db: ‘unconnected’ user: ‘root’ host: ‘’ (Got an error reading communication packets)”

There’s like 4 of these, connection 4, connection 7, etc.

Trying this image/setup instead - github com h44z/seafile-docker-ce

With that, I no longer get the mysql error, but I instead get a seafile error of:

2022/05/22 09:44:45 Problem with dial: dial tcp: lookup seafiledb on no such host. Sleeping 1s

and still no webui.