Ubuntu/Debian Package repository not working anymore


#1

deb. seadrive. org repositories are not working anymore.

apt-get update gives this error:
401 Unauthorized [IP: 104.18.58.193 80]


Err:11 http://deb.seadrive.org jessie Release 401 Unauthorized [IP: 104.18.59.193 80]
#2

Pulling this from another post of mine

It would appear that there is an issue with the repo, I am trying this on Ubuntu 18.04 and I did this:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 8756C4F765C9AC3CB6B85D62379CE192D401AB61
echo deb http://deb.seadrive.org bionic main | sudo tee /etc/apt/sources.list.d/seafile.list

This is the same as the guide on Seafile’s site except it switches jessie for bionic. This appears fine until I run sudo apt-get get update which results in an error

Err:5 http://deb.seadrive.org bionic Release                      
  401  Unauthorized [IP: 104.18.59.193 80]

When I visit the url of a deb file on the deb url, specifically
[seadrive-deb-domain]/bionic/pool/main/s/seadrive-daemon/seadrive-daemon_0.9.5_amd64.deb

I am then redirected to a P&G single sign on page, which does not make sense.

It would appear that something is misconfigured with respects to the deb server. Is there a timeline on when the repo will be fixed?

EDIT:

Looking at this further I noticed that if you disable JS that the browser does not auto redirect to the P&G site.


#3

I tested this on CentOS 7 with the instructions for seadrive and the RPM server is experiencing similar issues.


#4

Isn’t the “new” repo for ubuntu releases moved?
https://help.seafile.com/en/syncing_client/install_linux_client.html#wiki-ubuntu

Ubuntu users can install Seafile client from the Official PPA:

sudo add-apt-repository ppa:seafile/seafile-client
sudo apt-get update
sudo apt-get install seafile-gui


Regards Falk