Ubuntu upgrade 16.04.1 ... server works, but seafile does not

I’m running a private seafile server on a small-spec ubuntu 16.04 PC.
Just did a distro upgrade to 16.04.1 and it ran without major problems
The server is up and running again – apache is working, MySQL is working … all is well :slight_smile:
Except seafile isn’t working :confounded:

I can ssh into the server and (re-)starter seahub.sh and seafile.sh and ps will confirm seafile-control and seaf-server are running

But I can not sync via the linux app, nor access the http interface

Any suggestions what I should be looking at here?

In your linux client, click the “open logs folder” entry of of the tray menu, and check applet.log and seafile.log.

I’m getting lots of the network error listed below … thing is though, the server is working and I can visit the apache hosted sites I have running (phpmyadmin, a.o). It seems to be only when accessing http port 8000

[10/10/2016 03:46:21 PM][Daemon Mgr] stopping ccnet/seafile daemon
[10/11/2016 08:03:29 AM]starting ccnet:  ("-c", "/home/soon/.ccnet")
[10/11/2016 08:03:30 AM]trying to connect to ccnet daemon...

[10/11/2016 08:03:30 AM]connected to ccnet daemon

[10/11/2016 08:03:30 AM]starting seaf-daemon:  ("-c", "/home/soon/.ccnet", "-d", "/home/soon/Seafile/Seafile/.seafile-data", "-w", "/home/soon/Seafile/Seafile")
[10/11/2016 08:03:31 AM][Rpc Client] connected to daemon
[10/11/2016 08:03:33 AM][Rpc Client] connected to daemon
[10/11/2016 08:03:33 AM][MessageListener] connected to daemon
[10/11/2016 08:03:33 AM]Unable to get config value download_limit: Config not exists
[10/11/2016 08:03:33 AM]Unable to get config value upload_limit: Config not exists
[10/11/2016 08:03:33 AM]QString::arg: Argument missing: &Open cloud file browser, Seafile
[10/11/2016 08:03:33 AM][Rpc Client] connected to daemon
[10/11/2016 08:03:33 AM][api] network error for http://URL:8000/api2/ping/: Connection refused

[10/11/2016 08:03:33 AM][api] network error for http://URL:8000/api2/account/info/: Connection refused

[10/11/2016 08:03:33 AM][api] network error for http://URL:8000/api2/server-info/: Connection refused

[10/11/2016 08:03:33 AM]update server info failed Network Error: Connection refused

You mentioned “apache is working”, but from your logs you’re using port 8000. You should use http://URL (without 8000) in your seafile client.

It’s worked fine so far with the current client setup … up until the ubuntu server upgrade – I’ve not changed any settings on the client side.

On the server, I’m running a separate apache at port 81 for limesurvey, phpmyadmin and other stuff – all of that works flawlessly, which leads me to suspect that it must be the seafile specifically and at the server side that is causing problems.

I can ssh into my server as well. I have not made changes to the router port-forwarding either.

This line means seahub is not running. You can check the logs in seafile-server-latest/runtime directory to see if there is any error messge.

But that’s the thing … it is running.

soon@server:~/oneill/seafile-server-5.0.4$ sudo service
seafile-server start
soon@server:~/oneill/seafile-server-5.0.4$ ps -A | grep sea
23031 ?        00:00:00 seafile-control

…but still no luck :confused:

I think I will have to run through the system boot setup again, perhaps that is the problem – I have a script which shuts down (hibernates) the server at 10pm and wakes it up again at 07am. I’m thinking perhaps the ubuntu upgrade messed something up there

For anyone who comes by the thread at a later date:

  • I tried upgrading the seafile server (from 5.0.4 to 6.0.5) as well without luck

I am pretty sure the whole server setup was running, as was my database etc. But for some reason or other, the connection just couldn’t be established from my client.

In the end I delete the seafile (server) installation and started over – works just fine now. … and btw, it is a comfort to know that if the seafile server installation fails (as in this case), it is not too much hassle to restore your existing libraries.