Unable to Download/Upload files over Internet

I have a Working installation on windows. It works fine on my Local Intranet .
All options work fine.

I enable internet access, I am able to login, see my Library and its listings.
But I try to Download or Upload any file it gives error server took long time to respond and fails.
Any Advice. What could be wrong.
I even disabled windows internal firewall and tried no luck.

Check SERVICE_ULR and FILE_SERVER_ROOT. Those URL’s must work also from Internet.

Thanks for the reply.
I noted one thing, when I click the download button over the internet to download a file. I see that the external ip getting changed to my internal ip address on the address bar and definitely the download fails.
I tried changing the IP address to the external one manually and found the error page not found.
Why is this happening.
Thanks once again

Are you trying to configure Seafile to be accessible via different IPs? That is not possible - Seafile doesn’t support to be accessed via different URLs.

It seems I have the same problem since 2 days I can login my account but I can’t upload or download files in client or on web browser.
In the client i have “server error”, in web brower i have “bad token access”.
I’m on xubunu 16.04

It seems resolved