Unable to reach Seafile after removing garbage

Hi there,
I just tried to remove Seafile’s garbage on my CE installation following this tutorial https://manual.seafile.com/maintain/seafile_gc.html. As the root user, I first stopped the seafile and seahub servers, and then I ran ./seaf-gc.sh. Next, I tried to start up seafile and sehub again but received the following error Error: the user running the script ("root") is not the owner of "/opt/seafile/seafile-data" folder, you should use the user "seafile" to run the script.. To solve the problem I ran the following commands sudo -u seafile bash -c "./seafile.sh start" and sudo -u seafile bash -c "./seahub.sh start", which seem to start up just fine. For good measure, I also restarted NGINX. Unfortunately, when I try to access my Seafile server via a browser or the desktop client, I’m told “504 Gateway Time-out”. I can also see only one possible error message in all of the log files I checked, which is as follows (from ccnet.log):

[01/15/17 13:30:49] ../common/session.c(132): using config file /opt/seafile/conf/ccnet.conf [01/15/17 13:30:49] ../common/session.c(455): socket file exists, delete it anyway [01/15/17 13:30:49] ../common/session.c(484): Listen on /opt/seafile/ccnet/ccnet.sock for local clients [01/15/17 13:30:49] ../common/session.c(290): Update pubinfo file [01/15/17 13:30:50] ../common/session.c(398): Accepted a local client [01/15/17 13:30:50] ../common/session.c(398): Accepted a local client [01/15/17 13:30:50] ../common/session.c(398): Accepted a local client [01/15/17 13:30:50] ../common/session.c(398): Accepted a local client [01/15/17 13:30:58] ../common/session.c(398): Accepted a local client [01/15/17 13:30:58] ../common/peer.c(943): Local peer down

Any ideas of what could be going wrong?


Hi again,

Sorry to bother again about this. Today I decided to run “my” garbage collection script again, to see whether it would work no proble or not. Unfortunately, without changing anything from last week, I cannot start up the seahub server after garbage collection if I run seafile.hub start as the seafile user (Error:Seahub failed to start), but I can as the root user. Unfortunately, by doing so, I get a “504 Gateway Time-out” from the server when I try to access the seafile server via a browser. Once again the error that I get in ccnet.log is [01/22/17 19:49:05] ../common/peer.c(943): Local peer down, the seahub_django_request.log also contains this error message

File "/opt/seafile/seafile-server-6.0.7/seafile/lib64/python2.6/site-packages/ccnet/client.py", line 113, in connect_daemon_with_pipe raise NetworkError("Can't connect to daemon") NetworkError: Can't connect to daemon

Any ideas?