Upgrade 6.2.5 to 6.3.1 issue

Hello everybody,

I have the following problem upgrading seafile-server 6.2.5 to 6.3.1:

This script would upgrade your seafile server from 6.2 to 6.3
Press [ENTER] to contiune

Updating seafile/seahub database …

[INFO] You are using MySQL
[INFO] updating ccnet database…
[ERROR] Failed to execute sql: Duplicate column name 'parent_group_id’

Failed to upgrade your database

I have already seen a few forum entries, but I could not find a suitable answer.
Does anyone have an idea?
best regards

Same issue here

I think you have executed the upgrade script twice.

No, i have upgraded from 6.2.5 and run the upgrade script once.

The script exits before the upgrade is complete, gunicorn.conf not created so far so errors in startup

i modified the db manual as in sql and ignore the db upgrade sql and now the upgrade script without db part creates the gunicorn.conf and server starts normal.

1 Like

No, i have upgraded from 6.2.5 and run the upgrade script once.

Is the new Seafile version 6.3.1 now running? Can you show me yours what you’ve changed? Thank you

Hi,

i edited the upgrade_6.2_to_6.3.sh and comment out line 231 and run the script again.

before manual edit the database as in upgrade/sql/6.3.0/mysql required

problems occured with ccnet.sql

then server starts normal with 6.3.0

1 Like

Yes it works!!!
But i cant start ./seahub.sh

:~/haiwen/seafile-server-6.3.1$ ./seahub.sh start-fastcgi

LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub (fastcgi) at 127.0.0.1:8000 …
Unknown command: ‘runfcgi’
Type ‘manage.py help’ for usage.
Error:Seahub failed to start.

Fastcgi support has been dropped. You’ve to migrate to http.

1 Like

Thank you for your quick reply.
My Seafile page is no longer accessible via https.
Without https it’s not an option for me.
Could you explain how I switch Seafile to WSGI-Mode.
Thank’s!

okay, i solved the problem.
etc/apache2/sites-available/***.conf :

[…]
#seahub

SetEnvIf Authorization “(.*)” HTTP_AUTHORIZATION=$1
ProxyPass / http://127.0.0.1:8000/
ProxyPassReverse / http://127.0.0.1:8000/

2 Likes