Upgrade from 6.1.2 to 6.2.5 broken - ideas?

I upgraded from 6.1.2 to 6.2.5 (CE). I’m running Apache and use the SQLite backend. I did make the suggested Apache config changes. Everything was working fine on 6.1.2 (including the suggested Apache changes) but I thought I should stay updated so that I don’t fall too far behind and run into issues later.

Upgrade said it was successful. All services were restarted successfully. Accessing the GUI gets me the login but then it just sits there and nothing ever happens:


I tried in a new private session too (Chrome). Same thing.

The Windows and Linux clients 6.1.4 seem happy (I quite and then relaunched them to check).

Any clues why the web gui is broken?

Upgrade output and Apache config below:


This script would upgrade your seafile server from 6.1 to 6.2
Press [ENTER] to contiune

Updating seafile/seahub database …

[INFO] You are using SQLite3
[INFO] updating seahub database…
Done

migrating avatars …

Done

updating /seafile/server/seafile-server-latest symbolic link to /seafile/server/seafile-server-6.2.5 …


Upgraded your seafile server successfully.

Starting Seafile server …
starting seafile…
starting seahub…

Apache config:

<VirtualHost *:443>
    ServerName stor.example.com
    ServerAdmin stor@example.com

    DocumentRoot /var/www/stor.example.com

    <Directory /var/www/stor.example.com>
            Options -Indexes +FollowSymLinks +MultiViews
            AllowOverride All
            Require all granted
    </Directory>

    ## Seafile
    Alias /media /seafile/server/seafile-server-latest/seahub/media
    <Location /media>
            Require all granted
    </Location>

    ## seafile fileserver
    ProxyPass /seafhttp http://127.0.0.1:8082
    ProxyPassReverse /seafhttp http://127.0.0.1:8082
    RewriteRule ^/seafhttp - [QSA,L]

    ## seafdav webdav extension
    ProxyPass /seafdav http://127.0.0.1:8080/seafdav
    ProxyPassReverse /seafdav http://127.0.0.1:8080/seafdav
    RewriteRule ^/seafdav - [QSA,L]

    ## new WSGI for seahub (v6.2+)
    SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
    ProxyPass / http://127.0.0.1:8000/
    ProxyPassReverse / http://127.0.0.1:8000/

    ## Log levels: debug, info, notice, warn, error, crit, alert, emerg.
    ## You can add rewrite:<trace1,...,trace8> to also log rewrites.
    LogLevel notice
    #LogLevel notice rewrite:trace8

    ErrorLog ${APACHE_LOG_DIR}/seafile-error.log
    CustomLog ${APACHE_LOG_DIR}/seafile-access.log combined

    SSLEngine on
    SSLStrictSNIVHostCheck off
    SSLCertificateKeyFile /etc/letsencrypt/live/example.com/privkey.pem
    SSLCertificateFile /etc/letsencrypt/live/example.com/fullchain.pem
    <FilesMatch "\.(cgi|shtml|phtml|php)$">
            SSLOptions +StdEnvVars
    </FilesMatch>
    <Directory /usr/lib/cgi-bin>
            SSLOptions +StdEnvVars
    </Directory>
    BrowserMatch "MSIE [2-6]" \
            nokeepalive ssl-unclean-shutdown \
            downgrade-1.0 force-response-1.0
    BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown
</VirtualHost>

I am not sure if it is the problem, but comparing your conf with the manual one (https://manual.seafile.com/deploy/deploy_with_apache.html), yours lacks:

RewriteEngine On

The rewrite engine gets automatically enabled when using rewriterule, but activating the engine manually doesn’t hurt. Makes no difference in my case (seafile web gui still gets stuck)

What about changing to nginx? I’am running with it several pages, not only my seafile, and I think is much better than Apache2. You could make a backup and try it with nginx.