Upgrade not working - files not found


#1

Hi,

I’m having issues with upgrading - I’m on SF Pro, on version 6.3.4. I followed the upgrade instructions for the Docker container, but on re-launching, I’m getting “minor_upgrade.sh” not found. It looks like it’s looking for /opt/seafile/seafile-pro-server-6.3.4 - but since this is the newest version, that folder doesn’t exist.

How do I actually upgrade this? I tried launching the container and running it manually from the new versioned directory, (/opt/seafile/seafile-pro-server-6.3.11), but it was just giving me path errors. Just using versioned directories and trying to upgrade using the old version seems weird to me.

I tried updating the /shared/seafile/seafile-data/current_version file, but it’s still looking for the 6.3.4 directory. I feel like I’m missing a step, but I don’t see it documented in the upgrade guide.

Any help would be appreciated! Otherwise, I think I’ll spin up a Debian container and just slug through the installation guide for that, though I much prefer the container.

Thanks!


#2

Got it working - realized there was the version environment variable which needed updating. That probably should be put into the docs.