Upgrade script 7.0-7.1 configparser password issue (using %s)

Hi, I am experiencing the following issue when running the upgrade script from 7.0-7.1. Apparently something that has changed in python3 and configparser. The mysql password we use contains ‘%’, which causes the following error:


This script would upgrade your seafile server from 7.0 to 7.1
Press [ENTER] to contiune

renaming the gunicorn.conf to gunicorn.conf.py ...


Updating seafile/seahub database ...

Traceback (most recent call last):
  File "/data/seafile/seafile-pro-server-7.1.3/upgrade/db_update_helper.py", line 386, in <module>
  File "/data/seafile/seafile-pro-server-7.1.3/upgrade/db_update_helper.py", line 380, in main
    db_updater = DBUpdater.get_instance(version)
  File "/data/seafile/seafile-pro-server-7.1.3/upgrade/db_update_helper.py", line 86, in get_instance
    ccnet_db_info = DBUpdater.get_ccnet_mysql_info(version)
  File "/data/seafile/seafile-pro-server-7.1.3/upgrade/db_update_helper.py", line 164, in get_ccnet_mysql_info
    password = config.get(db_section, 'PASSWD')
  File "/usr/lib/python3.5/configparser.py", line 797, in get
  File "/usr/lib/python3.5/configparser.py", line 393, in before_get
    self._interpolate_some(parser, option, L, value, section, defaults, 1)
  File "/usr/lib/python3.5/configparser.py", line 443, in _interpolate_some
    "found: %r" % (rest,))
configparser.InterpolationSyntaxError: '%' must be followed by '%' or '(', found: '%Some%Dummy%Password%adasdcwad%wadasd'

Failed to upgrade your database

I had the same problem.
Removing the % from the password solved it.