Upload folder/files goes wrong


#1

Hello,

I noticed that when you upload folder and files, they become fixed up.

I upload a folder “workshare” (…/workshare/) with 6 documents in it and the rootfolder (./) with 30 files. All the files from the rootfolder go into the “workshare” folder when you upload via the website of seafile.

Is this normal?


#2

I’m not sure I understand what you are saying, but here’s a little blurb on it that may help.

Inside Seafile, you can create Libraries. Inside those libraries, you can then upload files and folders. Files can exist in the root of a library.

It sounds as if you have created a Library called “workshare”, and then you are trying to upload a folder called workshare into it that has subfolders and files in it. So, when you upload the workshare folder to the workshare library, it will be nested, like this.

workshare (library)
----- workshare (folder)
------ folder1
----- file1
------ folder2
----- file1
------ file1
------ file2

Please let me know if I understood you correctly…


#3

Are you sure it was really mixed up or only presented incorrectly after you uploaded it? Are they still mixed up after you refresh the page? I noticed that when I upload some files and then change the folder level, the files uploaded at that time appear in the new folder. However, this is only a display problem, they have actually been loaded into the original folder.


#4

To be clear:

I had a folder on drive C\my documents, with the following folders and files:

  • C:\my documents\workshare\rendering
    within, only these files (do not pay attention to the doubles):
    image

  • C:\my documents
    with 30 *.docx and *.pdf
    after using drag and drop on the website, all the individual files from the folder “my documents” are in workshare\rendering.
    I tried it twice, and they allways end up there.

I tried this also with files and folders from my H drive. There no problem occurred.


#5

So, you are saying you created a library called “workshare”.

Then, using drag and drop on the web ui, you dropped the C:\my documents\workshare\rendering folder into the “workshare” library. Everything fine, so far.

Then, you refreshed the view and made certain that you were still in the “worshare” library root, and not the “rendering” folder.

You then drag and drop the entire my documents folder into the “workshare” library.

If that’s your procedure, inside the “workshare” library, you should now have two folders… One called “rendering” and another called “my documents”.


#6

I think this is related to my post: WebUI folder and file uploading bug


#7

@1111

I’m unable to reproduce the problem. Works perfectly for me. My test info:

Chrome
Windows 10
Seafile Server CE ver 6.2.5
Stock SQLite
Nginx
Using SSL/https


#8

It is strange then. I just did another test over the latest Seafile version, but the problem persists.

Server Pro Version: 6.2.12
Chrome Version 66.0.3359.139 (Official Build) (64-bit)
Edition Windows 10 Enterprise, Version 1709, OS Build 16299.431
Server side configurations: MySQL, Apache as reverse proxy, With SSL/https

Now I suspect it could be caused by the reverse-proxy server. Nginx might not produce this issue.


#9

Yes, that’s possible. Could also be related to the Seafile interface to MySQL.

@float
Can you post your specs here and see if we can find a common thread between you and @1111?


#10

It is indeed the same problem as 1111.

Specs:

  • Pro: 6.2.12 with MySQL and nginx (ssl/https)
  • Windows 7
  • Firefox 52

#11

Can you also post your three Seafile logs here? Just the relevant entries at the time you initiated the upload that didn’t work as planned.


#12

I did this test too and the upload was as expected with firefox and chrome. With Safari folder upload does not work at all.

Mac OS El Capitan,
Server 6.2.5 CE,
NGINX,
Using SSL/https,
MySQL


#13

Which logfiles would you like? The upload was via the webgui.


#14

seafile.log and ccnet.log. Controller.log may help too. I’m trying to figure out whether it’s something with the webui itself or something between Seafile and MySQL.

Everyone of us has a different OS and using different browsers… Also, same with NGinx/Apache. Doesn’t seem OS, browser, or we server specific.

So far, comparing Simsala and myself, both of which work ok, with you two guys, the common threads are as follows.

Using Server 6.2.12 with MySQL over https. I seriously doubt it has anything to do with https. I’m suspecting a bug, but would like to narrow it down to exactly where the bug is.


#15

I checked the three log files, but there is no new entry at the time I upload the files.

I also test this on the Seafile Demo server https://seacloud.cc/demo, and find the same bug.


#16

After numerous testing, I finally figure out how to reliably reproduce this problem.
Actually, it has nothing to do with the server, just the browser’s or webUI’s problem.

I found it works:

  • correctly, if I first select the file, then select both file and folder, and then click-and-drag the file (with folder) into the browser;
  • incorrectly, if I first select the folder, then select both file and folder, and then click-and-drag the folder (with file) into the browser.

I record a short video clip to demonstrate this https://youtu.be/IGyJQkAgCw0


#17

I tried too, and got the same problem

Client :
Google Chrome 66.0.3359.170
Debian 9.4

Server :
Debian 9.4
seafile 6.2.12 PRO,
Apache2, using SSL/https
Mysql


#18

I may be able to shed a little light on this now that I’ve looked at how it works. If you choose “upload” from the menu, it then gives you an option for folder or files and you make a choice from there. So, I’m thinking that drag and drop takes a “guess” so to speak. So, if you drag and drop a file, it’s the equivalent of choosing upload then file. If you drag and drop a folder, it’s the equivalent of choosing upload then folder.

That’s my somewhat educated 2 cents worth. Either way, it’s certainly a bug.

@daniel.pan
Has this been reported previously?


#19

Any update on this issue?