Upload problems with Firefox 67.0.2 and 7.0.2 CE

I’m having problems uploading files using FF 67.0.2. The “Upload file” button or dragging a file into the window don’t work here.

I have tried a fresh profile in FF so that there are no intering add-ons. Still no luck.

But what does work fine for uploading are the Client 7.0.0 and the browsers Safari, Edge and IE11.

Anybody else having similar problems with FF?

No problem with the upload file dialog, but indeed, can’t upload by drag’n’drop since 7.0.2 CE or 7.0.3 PE when using Firefox (at least on Linux desktop). To be more precise, there’s an issue with the droping zone, because if you drop the file on the bottom of the left pane (Files, Tools etc…) instead of the right pane, the upload works.
No issue with Chrome

I can confirm that the file list area does not belong to the dropping zone since 7.x CE in the Firefox ESR series (60.7. / Windows) either. Other areas do work as described by @dani.

Button does work, but asks for opening a popup. @Whiskydrinker might FF 67 block that popup by default maybe?

It actually is the popup blocker of FF. I’ve just tried disabling it and then the dialog for choosing a file opens.

But that’s also kind of a strange behavior since FF normally asks if you want to allow a blocked popup. (The very same FF version does this e.g. in VMware Vcenter when opening a web console for a virtual machine.)


I can confirm that enabling popups in Firefox fixes the button issue. However, this is a quite serious bug since no feedback is given to the user by default.

However, drag’n’drop still doesn’t work.

Can confirm that both drag&drop and upload files does not work with FF.

I’m seeing the same problem with Firefox 67.0.4 on CE 7.0.2. Neither drag-and-drop nor Upload Files menu works when files are displayed in List view. I can drag-and-drop when files are displayed in Grid view but Upload Files still does not work. Enabling pop-ups in FF does not work.

I switched back to 6.3.4 for now. There are no major changes for me and nothing security related. Lets wait a little until a more stable version of 7 is ready.

I see the same problem here as well. Drag and Drop works (drop target must be one of the buttons on the top rather than the file list itself). Disabling popups helps as well. As a quick fix, I allowed popups for my seafile site selectively. But this is something that needs to be fixed ASAP.

Yes, I notice you can drop in the left sidebar as well just not the file list area.

FF is not specifically mentioned in the 7.0.3 CE changelog, but the button problem might be solved. At least on a clean FF profile on Linux Mint the button is working now out of the box. Can’t test on other systems atm.

The upload button now works here, too. But the bug that you can’t drag a file into the the library part of the window is still there.