URGENT! LDAP failed after upgrading Pro server


#21

Hi,

I tried both solutions, with or without boundled libraries, but connection still fails when I try to use ldaps.
In ccnet.log, there is:
ldap_bind failed for user Manager: Can’t contact LDAP server.

A tshark examination of the traffic to and from the ldaps server shows that after SYN, SYN ACK, the client immediately send a FYN.

Simple unencrypted ldap works fine.


#22

As described earlier, I also tried to remove the bundled libraries without success. We have bought a valid pro license and like to get ldaps work again. The fact that ldapsync works with ldaps makes me think that it should not be a big problem to make ldapbind also work again.


#23

Now the package is built on CentOS 6. So there could be binary compatibility problem with CentOS 7’s ssl related libraries. We’ll build it for CentOS 7 soon. I think that would solve the problem.


#24

Dear Jonathan,

thank you so much for that, and also for all your work on seafile.

Leo


#25

Sounds great :slight_smile:
Thanks.


#26

Hi,

I just installed the latest pro version 6.1.3. LDAPS is still not working. Did you compile it on CentOS 7?


#27

Sorry we haven’t had the time to do so yet.


#28

Now, half a year after the problem first occured, it is still not resolved. I just installed the latest Seafile pro 6.1.9 and still can not connect via LDAPS to our ldap server on RedHat 7.3. :worried:


#29

You should really take the time to create the CentOS 7 packages, because this is getting a security issue. Now the GLIBC packages are depending on the newer NSS and NSPR libraries. Until now one could hold back only the relevant libraries to keep Seafile working with LDAP authentication. Now it means you cannot update nearly a single package… Please raise the priority for this problem!


#30

We’re already working on it.


#31

Still? The anniversary is approaching for this bug.
@daniel.pan If you are officially supporting CentOS 7 then this should really not happen.


#32

No, LDAPS authentication works meanwhile on centos 7 :slight_smile:


#33

Finally! :smiley: Thank you for your reply!
Would have been worth mentioning in the changelog…


#34

Could you please share the knowledge how to get LDAPS to work on CentOS 7 ? :slight_smile: I’ve just updated Seafile to 6.2.5 and still no luck – “Can’t contact LDAP server”. With LDAP works OK.