URL change is not reflected when Seafile creates shared links

Hi,

in the past I was running my Seafile server on my domain on port 8080, because the real SSL port of my home IP was “blocked” by my groupware server, doing Active Sync on it.

I’ve put that behind a web proxy now, so I can divide the incoming traffic related to the called URL. Works pretty well!

So, the old URL for my Seafile installation was: https://mycloudurl.de:8080
Now I want to use https://mycloudurl.de

I did change all URL references in the /conf folder in:

  • ccnet.conf
  • seahub-settings.py

I’ve deleted seahub-settings.pyc and restarted the seafile service and the seahub service.

When I now call my Seafile installation with https://mycloudurl.de all works well - but when I create a share link for a file, the newly created link always shows: https://mycloudurl.de:8080/

What did I overlook that Seafile still uses the old “:8080” which I’ve deleted in the configuration files above?

OK - I’ve found it! There are also URL configurations in the Seafile settings accessable via the webserver. I needed to change them here also!