utf-8 at the start of the filename

When I download a file from a link on my seafile server with the Internet Download Manager (IDM) extension in the browser, it adds utf-8’ ’ at the start of the filename.
Like this:

utf-8’ 'test.zip

While when I download with only the browser (IDM extension turned off) the filename is spelled the right way.
This is the right way:

test.zip

Could that be a problem with the IDM-software, or what happened? Do I have to set something in the seafile conf file(s).?

FYI:
seafile-pro-server_10.0.8 Ubuntu

I got a reply back from IDM, and they told us there is some mistake in HTTP headers on our Seafile external download page with a test-zip link. They will implement a work-around for it on their side, but still, on our side there is probably something wrong with the HTTP headers.We followed the manual. Can’t find anything related to this problem. Or perhaps it’s an Apache setting not right.

If anyone has a thought about it?