Version `libmariadbclient_18' not found

Hi, I installed SW updates 2 weeks ago and from that operation Seahub stop working. I know, it’s not Seafile problem, MariaDB developers confirm this bug (PureFTP wit mysql plugin not working too). But it’s 2 weeks and our company cannot wait to infinity. I’m looking for some temp solution to get Seahub working. Seafile server (read seafile service) looks working, but Seahub does not starting (see log below), so I cannot login clients and mobile apps.

Thanks for reply

LC_ALL is not set in ENV, set to en_US.UTF-8
/haiwen/seafile-server-latest/ řádek 209: varování: setlocale: LC_ALL: národní prostředí nelze změnit (en_US.UTF-8): Adresář nebo soubor neexistuje
Starting seahub (fastcgi) at ...
Traceback (most recent call last):
  File "/haiwen/seafile-server-6.1.2/seahub/", line 10, in <module>
  File "/haiwen/seafile-server-6.1.2/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/core/management/", line 354, in execute_from_command_line
  File "/haiwen/seafile-server-6.1.2/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/core/management/", line 328, in execute
  File "/haiwen/seafile-server-6.1.2/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/", line 18, in setup
  File "/haiwen/seafile-server-6.1.2/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/apps/", line 85, in populate
    app_config = AppConfig.create(entry)
  File "/haiwen/seafile-server-6.1.2/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/apps/", line 86, in create
    module = import_module(entry)
  File "/usr/lib/python2.7/importlib/", line 37, in import_module
  File "/haiwen/seafile-server-6.1.2/seahub/seahub/contacts/", line 3, in <module>
    from handlers import *
  File "/haiwen/seafile-server-6.1.2/seahub/seahub/contacts/", line 4, in <module>
    from models import Contact
  File "/haiwen/seafile-server-6.1.2/seahub/seahub/contacts/", line 54, in <module>
    class Contact(models.Model):
  File "/haiwen/seafile-server-6.1.2/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/db/models/", line 139, in __new__
    new_class.add_to_class('_meta', Options(meta, **kwargs))
  File "/haiwen/seafile-server-6.1.2/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/db/models/", line 324, in add_to_class
    value.contribute_to_class(cls, name)
  File "/haiwen/seafile-server-6.1.2/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/db/models/", line 250, in contribute_to_class
    self.db_table = truncate_name(self.db_table, connection.ops.max_name_length())
  File "/haiwen/seafile-server-6.1.2/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/db/", line 36, in __getattr__
    return getattr(connections[DEFAULT_DB_ALIAS], item)
  File "/haiwen/seafile-server-6.1.2/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/db/", line 241, in __getitem__
    backend = load_backend(db['ENGINE'])
  File "/haiwen/seafile-server-6.1.2/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/db/", line 112, in load_backend
    return import_module('%s.base' % backend_name)
  File "/usr/lib/python2.7/importlib/", line 37, in import_module
  File "/haiwen/seafile-server-6.1.2/seahub/thirdpart/Django-1.8.18-py2.7.egg/django/db/backends/mysql/", line 27, in <module>
    raise ImproperlyConfigured("Error loading MySQLdb module: %s" % e)
django.core.exceptions.ImproperlyConfigured: Error loading MySQLdb module: /usr/lib/x86_64-linux-gnu/ version `libmariadbclient_18' not found (required by /usr/lib/python2.7/dist-packages/
Error:Seahub failed to start.

Thanks for reply.

But how I sad. I’m solving this for 2 weeks. This answer I found as first and try nothing changed. There is maybe problem that I’m using MariaDB no MySQL (look at the log - libmariadbclient not libmysqldbclient). And I never had error cannot open shared object file no matter of file name. This problem they fix by autocreating simlink for libmysqlclient but they still not fixed version error.

I just solved this problem. I downgraded MariaDB and all libraries from 10.2 to 10.1. Please can you write some warning for other people to use default debian repositories for mariadb and do not install v10.2 on Debian 9.