Web GUI - rename, new folder, share not possible

Hi there,
since I upgraded to the first 7.0.x Pro version the modals in the web interface do not work anymore (rename, new folder, sharing). I tried checking it with dev tools in Chrome, and it seems there are no CSS styles for the modal div, plus the modal window stays empty as well (but I don’t know the exact logic behind the web interface). Also, the Help/About links are being overlayed by the navigation pane on the left side, so you can’t click them either.
Downloading and deleting do work, but no notice is shown as it usually would (building zip file etc.) so I guess it’s more or less a CSS/JS issue.
This has stayed even with a 7.0.7 update today. Any ideas?

I can remember that I had a similar issue. I’ve simply changed the Service URL in ccnet.conf to fix it. Maybe it’s also the same issue? But I updated from 7.0.2 CE to 7.0.4 CE.

Hi Johnii, I read about that, thanks for pointing that out. But what should the service URL look like? It’s the normal URL of my Seafile web front end already :slight_smile: .

Do you proxy trough Apache/NGINX with HTTPS or without? So if you proxy with HTTPS just change your URL from http://[IP or DOMAIN]:8000 to https://[IP or DOMAIN] .

In my case I switched from http://cloud.jotoma.de:8000 to https://cloud.jotoma.de .

It’s nginx with https, and had been set and is still set to the right https://mydomain.com URL, without any additional ports etc. :confused:

Hmm… strange. It could also be a bug because I see some more people with similar issues. Dunno what the dev’s done wrong… :slight_smile:

@enoversum have you tried deleteing the contents of /tmp/seahub_cache or flusing memcached? It is always worth, to check it.

1 Like

Yes, and it didn’t change anything. Until I inspected the CSS to realise I have some custom CSS running that literally hid things since the 7.0.x updates (Seafile obviously changed classes). Now it’s fixed, could have had the idea a tad bit earlier :slight_smile: .
Thanks everyone for your help!