Web upload large files issue

Hi!
We have problems to upload larger files (200 Mb and more).

We try the Pro Edition 6.13 on ubuntu LTS 16.04, with mysql.

Seafile w/o proxy is ok.

After installed apache as proxy we can’t upload large files (small files like 50MB are without an issue).
Now we try out nginx: same issue.
After time out the web interface gives “Unkown error”. (apache and nginx)
I could not find anything in logfiles.

The config files are all the default versions.

Is there a know issue with fastcgi and large files?
I checked filesize settings an all other stuff, but the issue is still remaining.

We use seafile a copple of years as comunity version without any problems. (of course, our comunity version is 5.09)

Nginx vhost config files please.
Did you set the timeout value for large files in the seahub settings?

Hi, here are my nginx settings. I have the same issue with apache.

Default setting from seafile manual: (https://manual.seafile.com/deploy/deploy_with_nginx.html)

server {
            listen 80;
            server_name seafile.example.com;

            proxy_set_header X-Forwarded-For $remote_addr;

            location / {
                fastcgi_pass    127.0.0.1:8000;
                fastcgi_param   SCRIPT_FILENAME     $document_root$fastcgi_script_name;
                fastcgi_param   PATH_INFO           $fastcgi_script_name;

                fastcgi_param    SERVER_PROTOCOL        $server_protocol;
                fastcgi_param   QUERY_STRING        $query_string;
                fastcgi_param   REQUEST_METHOD      $request_method;
                fastcgi_param   CONTENT_TYPE        $content_type;
                fastcgi_param   CONTENT_LENGTH      $content_length;
                fastcgi_param    SERVER_ADDR         $server_addr;
                fastcgi_param    SERVER_PORT         $server_port;
                fastcgi_param    SERVER_NAME         $server_name;
                fastcgi_param   REMOTE_ADDR         $remote_addr;

                access_log      /var/log/nginx/seahub.access.log;
                error_log       /var/log/nginx/seahub.error.log;
                fastcgi_read_timeout 36000;
                client_max_body_size 0;
            }

            location /seafhttp {
                rewrite ^/seafhttp(.*)$ $1 break;
                proxy_pass http://127.0.0.1:8082;
                client_max_body_size 0;
                proxy_connect_timeout  36000s;
                proxy_read_timeout  36000s;
                proxy_send_timeout  36000s;
                send_timeout  36000s;
            }

            location /media {
                root /home/user/haiwen/seafile-server-latest/seahub;
            }
        }

In seahub-settings I tried with and without timeout settings:
seafile.conf, area [fileserver] -> web_token_expire_time=3600

What about the temp folder size? Can you watch the drive I/O and space while uploading?
There might be an issue with the temp directory or the system has an issue pushing the files to the server.

File permission is still correct?
Did you run all upgrade script when upgrading from CE to PRO?

This is a new server with a sep. installation. File permission is correct. Files with 70MB or 100MB were uploaded.
At this moment I try other files like .7z and .zip instead of .mp4 or .exe.
temp folder is ok and I have no entries in the system logs.

I dont know what happend, but now there are no problems with uploading any files. I am confused. I changed nothing since yesterday.
Now I have my windows 10 workstation in suspicion (or my local hard disks).
:confounded:

I will test some other files now… this is strange.

Did you properly restart nginx and Seafile after the changes?

I restored the nginx config file back to ssl (and restart it) and restart the seahub (since yetserday I have testet on port 80).

The first try to upload a large (450MB) file was a timeout, I zipped it (from mp4 to 7z) - and now -> tried it as 7z and now all files upload without any timeout. :confused:

I will test many files today…

If this only happens with video files it might have to do with the fact that the system tries to create video thumbnails. Maybe disable this feature and try again.

# Enable or disable thumbnail for video. ffmpeg and moviepy should be installed first. 
# For details, please refer to https://manual.seafile.com/deploy/using_sqlite.html
# NOTE: since version 6.1
ENABLE_VIDEO_THUMBNAIL = False